{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-25566 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2023-25566 is a high-severity denial of service vulnerability in gssapi gss-ntlmssp, published on 14 Feb 2023. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-25566 and fix it if it is affected.\n\nWhat it is: CVE-2023-25566 is a high-severity denial of service vulnerability in gssapi gss-ntlmssp, published on 14 Feb 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-25566 in the wild and no public exploit code.\n\nAffected product: gssapi gss-ntlmssp. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-25566/ (Markdown: https://insights.sbomify.com/CVE-2023-25566/index.md)","id":"CVE-2023-25566","markdown":"https://insights.sbomify.com/CVE-2023-25566/index.md","name":"CVE-2023-25566","record":{"aliases":["AZL-43471","AZL-44997","DEBIAN-CVE-2023-25566","GHSA-mfm4-6g58-jw74"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"GSS-NTLMSSP library","requires_auth":"none","summary":"An attacker can cause a denial of service by triggering a memory leak during username parsing in the GSS-NTLMSSP library.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"gss-ntlmssp","vendor":"gss-ntlmssp_project"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-401","name":"Missing Release of Memory after Effective Lifetime"}],"description":"GSS-NTLMSSP is a mechglue plugin for the GSSAPI library that implements NTLM authentication. Prior to version 1.2.0, a memory leak can be triggered when parsing usernames which can trigger a denial-of-service. The domain portion of a username may be overridden causing an allocated memory area the size of the domain name to be leaked. An attacker can leak memory via the main `gss_accept_sec_context` entry point, potentially causing a denial-of-service. This issue is fixed in version 1.2.0.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"GSS-NTLMSSP vulnerable to memory leak when parsing usernames","id":"CVE-2023-25566","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"denial_of_service","year":"2023"},"n_packages":0,"n_references":3,"next":{"headline":"GSS-NTLMSSP vulnerable to out-of-bounds read when decoding target information","id":"CVE-2023-25567"},"packages":[],"prev":{"headline":"GSS-NTLMSSP vulnerable to incorrect free when decoding target information","id":"CVE-2023-25565"},"products":["gss-ntlmssp"],"published":"2023-02-14","related":[{"cvss_score":7.5,"headline":"GSS-NTLMSSP vulnerable to incorrect free when decoding target information","id":"CVE-2023-25565","kev_date_added":null,"published":"2023-02-14"},{"cvss_score":7.5,"headline":"GSS-NTLMSSP vulnerable to out-of-bounds read when decoding target information","id":"CVE-2023-25567","kev_date_added":null,"published":"2023-02-14"},{"cvss_score":6.5,"headline":"GSS-NTLMSSP vulnerable to memory corruption when decoding UTF16 strings","id":"CVE-2023-25564","kev_date_added":null,"published":"2023-02-14"},{"cvss_score":5.9,"headline":"GSS-NTLMSSP vulnerable to multiple out-of-bounds reads when decoding NTLM fields","id":"CVE-2023-25563","kev_date_added":null,"published":"2023-02-14"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-03-10","vendors":["gssapi"]},"summary":"An attacker can cause a denial of service by triggering a memory leak during username parsing in the GSS-NTLMSSP library.","url":"https://insights.sbomify.com/CVE-2023-25566/"}