# CVE-2023-25566: GSS-NTLMSSP vulnerable to memory leak when parsing usernames

> An attacker can cause a denial of service by triggering a memory leak during username parsing in the GSS-NTLMSSP library.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Feb 2023
- **Updated:** 10 Mar 2025
- **Also known as:** AZL-43471, AZL-44997, DEBIAN-CVE-2023-25566, GHSA-mfm4-6g58-jw74

## What is CVE-2023-25566?

CVE-2023-25566 is a high-severity denial of service vulnerability in gssapi gss-ntlmssp, published on 14 Feb 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

GSS-NTLMSSP is a mechglue plugin for the GSSAPI library that implements NTLM authentication. Prior to version 1.2.0, a memory leak can be triggered when parsing usernames which can trigger a denial-of-service. The domain portion of a username may be overridden causing an allocated memory area the size of the domain name to be leaked. An attacker can leak memory via the main `gss_accept_sec_context` entry point, potentially causing a denial-of-service. This issue is fixed in version 1.2.0.

Weakness: CWE-401 (Missing Release of Memory after Effective Lifetime)

## Which versions are affected by CVE-2023-25566?

It affects 1 product.


Products: Gss-Ntlmssp Project Gss-Ntlmssp.

## How do I fix CVE-2023-25566?

Upgrade to a fixed version.

## Is CVE-2023-25566 being exploited?

There is no known exploitation of CVE-2023-25566 in the wild and no public exploit code.

## Other vulnerabilities in gssapi gss-ntlmssp

- [CVE-2023-25565](https://insights.sbomify.com/CVE-2023-25565/): GSS-NTLMSSP vulnerable to incorrect free when decoding target information (high 7.5)
- [CVE-2023-25567](https://insights.sbomify.com/CVE-2023-25567/): GSS-NTLMSSP vulnerable to out-of-bounds read when decoding target information (high 7.5)
- [CVE-2023-25564](https://insights.sbomify.com/CVE-2023-25564/): GSS-NTLMSSP vulnerable to memory corruption when decoding UTF16 strings (medium 6.5)
- [CVE-2023-25563](https://insights.sbomify.com/CVE-2023-25563/): GSS-NTLMSSP vulnerable to multiple out-of-bounds reads when decoding NTLM fields (medium 5.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-25566 and fix it if it is affected.

What it is: CVE-2023-25566 is a high-severity denial of service vulnerability in gssapi gss-ntlmssp, published on 14 Feb 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-25566 in the wild and no public exploit code.

Affected product: gssapi gss-ntlmssp. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-25566/ (Markdown: https://insights.sbomify.com/CVE-2023-25566/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-25566
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-25566
- OSV: https://osv.dev/vulnerability/CVE-2023-25566

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-25566/
Summaries are generated and may contain mistakes; the official description above is the record.
