# CVE-2023-25569: apollo-portal has potential CSRF issue

> A low-privileged user can trick an admin into granting themselves higher privileges via a crafted webpage in Apollo Portal.

- **Severity:** Medium 5.7 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 20 Feb 2023
- **Updated:** 10 Mar 2025
- **Also known as:** GHSA-fmxq-v8mg-qh25

## What is CVE-2023-25569?

CVE-2023-25569 is a medium-severity vulnerability in apolloconfig apollo, published on 20 Feb 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Apollo is a configuration management system. Prior to version 2.1.0, a low-privileged user can create a special web page. If an authenticated portal admin visits this page, the page can silently send a request to assign new roles for that user without any confirmation from the Portal admin. Cookie SameSite strategy was set to Lax in version 2.1.0. As a workaround, avoid visiting unknown source pages.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2023-25569?

2 open source packages ship an affected version, including com.ctrip.framework.apollo:apollo. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.ctrip.framework.apollo:apollo` | Maven | All versions | 2.1.0 |
| `com.ctrip.framework.apollo:apollo` | Maven | All versions | 2.1.0 |

Products: Apolloconfig Apollo.

## How do I fix CVE-2023-25569?

Upgrade com.ctrip.framework.apollo:apollo to 2.1.0 or later.

## Is CVE-2023-25569 being exploited?

There is no known exploitation of CVE-2023-25569 in the wild and no public exploit code.

## Other vulnerabilities in apolloconfig apollo

- [CVE-2024-42662](https://insights.sbomify.com/CVE-2024-42662/): Information disclosure in n/a (high 7.5)
- [CVE-2023-25570](https://insights.sbomify.com/CVE-2023-25570/): Apollo has potential access control security issue in eureka (high 7.5)
- [CVE-2024-43397](https://insights.sbomify.com/CVE-2024-43397/): Potential unauthorized access issue in apollo-portal (medium 4.3)
- [CVE-2022-4962](https://insights.sbomify.com/CVE-2022-4962/): Apollo Configuration Center users improper authorization (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-25569 and fix it if it is affected.

What it is: CVE-2023-25569 is a medium-severity vulnerability in apolloconfig apollo, published on 20 Feb 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-25569 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.ctrip.framework.apollo:apollo (Maven): affected all versions; fixed in 2.1.0
- com.ctrip.framework.apollo:apollo (Maven): affected all versions; fixed in 2.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-25569/ (Markdown: https://insights.sbomify.com/CVE-2023-25569/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-25569
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-25569
- OSV: https://osv.dev/vulnerability/CVE-2023-25569

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-25569/
Summaries are generated and may contain mistakes; the official description above is the record.
