{"answers":{"affected":"2 open source packages ship an affected version, including com.ctrip.framework.apollo:apollo. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-25570 in the wild and no public exploit code.","fix":"Upgrade com.ctrip.framework.apollo:apollo to 2.1.0 or later.","what":"CVE-2023-25570 is a high-severity missing authorization vulnerability in apolloconfig apollo, published on 20 Feb 2023. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-25570 and fix it if it is affected.\n\nWhat it is: CVE-2023-25570 is a high-severity missing authorization vulnerability in apolloconfig apollo, published on 20 Feb 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-25570 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- com.ctrip.framework.apollo:apollo (Maven): affected all versions; fixed in 2.1.0\n- com.ctrip.framework.apollo:apollo (Maven): affected all versions; fixed in 2.1.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-25570/ (Markdown: https://insights.sbomify.com/CVE-2023-25570/index.md)","id":"CVE-2023-25570","markdown":"https://insights.sbomify.com/CVE-2023-25570/index.md","name":"CVE-2023-25570","record":{"aliases":["GHSA-368x-wmmg-hq5c"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["security_bypass","data_modify"],"network_reachable":"yes","non_default_config":true,"product_category":"Apollo configuration system","requires_auth":"none","summary":"Attackers can bypass authentication to mock Apollo services if the config service is exposed to the internet without proper network restrictions.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"apollo","vendor":"apolloconfig"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-306","name":"Missing Authentication for Critical Functionality"}],"description":"Apollo is a configuration management system. Prior to version 2.1.0, there are potential security issues if users expose apollo-configservice to the internet, which is not recommended. This is because there is no authentication feature enabled for the built-in eureka service. Malicious hackers may access eureka directly to mock apollo-configservice and apollo-adminservice. Login authentication for eureka was added in version 2.1.0. As a workaround, avoid exposing apollo-configservice to the internet.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apollo has potential access control security issue in eureka","id":"CVE-2023-25570","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"missing_authorization","year":"2023"},"n_packages":2,"n_references":4,"next":{"headline":"Backstage has XSS Vulnerability in Software Catalog","id":"CVE-2023-25571"},"packages":[{"ecosystem":"Maven","fixed":["2.1.0"],"introduced":["0"],"last_affected":[],"package":"com.ctrip.framework.apollo:apollo","purl":null,"source":"GHSA-368x-wmmg-hq5c"},{"ecosystem":"Maven","fixed":["2.1.0"],"introduced":["0"],"last_affected":[],"package":"com.ctrip.framework.apollo:apollo","purl":"pkg:maven/com.ctrip.framework.apollo/apollo","source":"GHSA-368x-wmmg-hq5c"}],"prev":{"headline":"apollo-portal has potential CSRF issue","id":"CVE-2023-25569"},"products":["apollo"],"published":"2023-02-20","related":[{"cvss_score":7.5,"headline":"Information disclosure in n/a","id":"CVE-2024-42662","kev_date_added":null,"published":"2024-08-20"},{"cvss_score":5.7,"headline":"apollo-portal has potential CSRF issue","id":"CVE-2023-25569","kev_date_added":null,"published":"2023-02-20"},{"cvss_score":4.3,"headline":"Potential unauthorized access issue in apollo-portal","id":"CVE-2024-43397","kev_date_added":null,"published":"2024-08-20"},{"cvss_score":4.3,"headline":"Apollo Configuration Center users improper authorization","id":"CVE-2022-4962","kev_date_added":null,"published":"2024-01-12"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-03-10","vendors":["apolloconfig"]},"summary":"Attackers can bypass authentication to mock Apollo services if the config service is exposed to the internet without proper network restrictions.","url":"https://insights.sbomify.com/CVE-2023-25570/"}