# CVE-2023-25570: Apollo has potential access control security issue in eureka

> Attackers can bypass authentication to mock Apollo services if the config service is exposed to the internet without proper network restrictions.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Feb 2023
- **Updated:** 10 Mar 2025
- **Also known as:** GHSA-368x-wmmg-hq5c

## What is CVE-2023-25570?

CVE-2023-25570 is a high-severity missing authorization vulnerability in apolloconfig apollo, published on 20 Feb 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Apollo is a configuration management system. Prior to version 2.1.0, there are potential security issues if users expose apollo-configservice to the internet, which is not recommended. This is because there is no authentication feature enabled for the built-in eureka service. Malicious hackers may access eureka directly to mock apollo-configservice and apollo-adminservice. Login authentication for eureka was added in version 2.1.0. As a workaround, avoid exposing apollo-configservice to the internet.

Weakness: CWE-306 (Missing Authentication for Critical Functionality)

## Which versions are affected by CVE-2023-25570?

2 open source packages ship an affected version, including com.ctrip.framework.apollo:apollo. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.ctrip.framework.apollo:apollo` | Maven | All versions | 2.1.0 |
| `com.ctrip.framework.apollo:apollo` | Maven | All versions | 2.1.0 |

Products: Apolloconfig Apollo.

## How do I fix CVE-2023-25570?

Upgrade com.ctrip.framework.apollo:apollo to 2.1.0 or later.

## Is CVE-2023-25570 being exploited?

There is no known exploitation of CVE-2023-25570 in the wild and no public exploit code.

## Other vulnerabilities in apolloconfig apollo

- [CVE-2024-42662](https://insights.sbomify.com/CVE-2024-42662/): Information disclosure in n/a (high 7.5)
- [CVE-2023-25569](https://insights.sbomify.com/CVE-2023-25569/): apollo-portal has potential CSRF issue (medium 5.7)
- [CVE-2024-43397](https://insights.sbomify.com/CVE-2024-43397/): Potential unauthorized access issue in apollo-portal (medium 4.3)
- [CVE-2022-4962](https://insights.sbomify.com/CVE-2022-4962/): Apollo Configuration Center users improper authorization (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-25570 and fix it if it is affected.

What it is: CVE-2023-25570 is a high-severity missing authorization vulnerability in apolloconfig apollo, published on 20 Feb 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-25570 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.ctrip.framework.apollo:apollo (Maven): affected all versions; fixed in 2.1.0
- com.ctrip.framework.apollo:apollo (Maven): affected all versions; fixed in 2.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-25570/ (Markdown: https://insights.sbomify.com/CVE-2023-25570/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-25570
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-25570
- OSV: https://osv.dev/vulnerability/CVE-2023-25570

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-25570/
Summaries are generated and may contain mistakes; the official description above is the record.
