{"answers":{"affected":"6 open source packages ship an affected version, including @backstage/catalog-model, @backstage/core-components and @backstage/plugin-catalog-backend. It affects 3 products.","exploited":"There is no known exploitation of CVE-2023-25571 in the wild and no public exploit code.","fix":"Upgrade @backstage/catalog-model to 1.2.0 or later.","what":"CVE-2023-25571 is a medium-severity cross-site scripting vulnerability in backstage, published on 14 Feb 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2023-25571 and fix it if it is affected.\n\nWhat it is: CVE-2023-25571 is a medium-severity cross-site scripting vulnerability in backstage, published on 14 Feb 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2023-25571 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- @backstage/catalog-model (npm): affected all versions; fixed in 1.2.0\n- @backstage/catalog-model (npm): affected all versions; fixed in 1.2.0\n- @backstage/core-components (npm): affected all versions; fixed in 0.12.4\n- @backstage/core-components (npm): affected all versions; fixed in 0.12.4\n- @backstage/plugin-catalog-backend (npm): affected all versions; fixed in 1.7.2\n- @backstage/plugin-catalog-backend (npm): affected all versions; fixed in 1.7.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-25571/ (Markdown: https://insights.sbomify.com/CVE-2023-25571/index.md)","id":"CVE-2023-25571","markdown":"https://insights.sbomify.com/CVE-2023-25571/index.md","name":"CVE-2023-25571","record":{"aliases":["GHSA-7hv8-3fr9-j2hv"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Backstage developer portal","requires_auth":"low_privilege","summary":"Attackers with catalog write access can inject malicious scripts via URLs, leading to XSS when users click them.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"backstage_catalog-model","vendor":"linuxfoundation"},{"product":"backstage_core-components","vendor":"linuxfoundation"},{"product":"backstage_plugin-catalog-backend","vendor":"linuxfoundation"}],"cvss":{"score":6.8,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-84","name":"Improper Neutralization of Encoded URI Schemes in a Web Page"},{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Backstage is an open platform for building developer portals. `@backstage/catalog-model` prior to version 1.2.0, `@backstage/core-components` prior to 0.12.4, and `@backstage/plugin-catalog-backend` prior to 1.7.2 are affected by a cross-site scripting vulnerability. This vulnerability allows a malicious actor with access to add or modify content in an instance of the Backstage software catalog to inject script URLs in the entities stored in the catalog. If users of the catalog then click on said URLs, that can lead to an XSS attack.\n\nThis vulnerability has been patched in both the frontend and backend implementations. The default `Link` component from `@backstage/core-components` version 1.2.0 and greater will now reject `javascript:` URLs, and there is a global override of `window.open` to do the same. In addition, the catalog model v0.12.4 and greater as well as the catalog backend v1.7.2 and greater now has additional validation built in that prevents `javascript:` URLs in known annotations. As a workaround, the general practice of limiting access to modifying catalog content and requiring code reviews greatly help mitigate this vulnerability.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Backstage has XSS Vulnerability in Software Catalog","id":"CVE-2023-25571","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2023"},"n_packages":6,"n_references":2,"next":{"headline":"React-Admin vulnerable to Cross-Site-Scripting attack on `\u003cRichTextField\u003e`","id":"CVE-2023-25572"},"packages":[{"ecosystem":"npm","fixed":["1.2.0"],"introduced":["0"],"last_affected":[],"package":"@backstage/catalog-model","purl":null,"source":"GHSA-7hv8-3fr9-j2hv"},{"ecosystem":"npm","fixed":["1.2.0"],"introduced":["0"],"last_affected":[],"package":"@backstage/catalog-model","purl":"pkg:npm/%40backstage/catalog-model","source":"GHSA-7hv8-3fr9-j2hv"},{"ecosystem":"npm","fixed":["0.12.4"],"introduced":["0"],"last_affected":[],"package":"@backstage/core-components","purl":null,"source":"GHSA-7hv8-3fr9-j2hv"},{"ecosystem":"npm","fixed":["0.12.4"],"introduced":["0"],"last_affected":[],"package":"@backstage/core-components","purl":"pkg:npm/%40backstage/core-components","source":"GHSA-7hv8-3fr9-j2hv"},{"ecosystem":"npm","fixed":["1.7.2"],"introduced":["0"],"last_affected":[],"package":"@backstage/plugin-catalog-backend","purl":null,"source":"GHSA-7hv8-3fr9-j2hv"},{"ecosystem":"npm","fixed":["1.7.2"],"introduced":["0"],"last_affected":[],"package":"@backstage/plugin-catalog-backend","purl":"pkg:npm/%40backstage/plugin-catalog-backend","source":"GHSA-7hv8-3fr9-j2hv"}],"prev":{"headline":"Apollo has potential access control security issue in eureka","id":"CVE-2023-25570"},"products":["backstage"],"published":"2023-02-14","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-03-10","vendors":["backstage"]},"summary":"Attackers with catalog write access can inject malicious scripts via URLs, leading to XSS when users click them.","url":"https://insights.sbomify.com/CVE-2023-25571/"}