# CVE-2023-25571: Backstage has XSS Vulnerability in Software Catalog

> Attackers with catalog write access can inject malicious scripts via URLs, leading to XSS when users click them.

- **Severity:** Medium 6.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 14 Feb 2023
- **Updated:** 10 Mar 2025
- **Also known as:** GHSA-7hv8-3fr9-j2hv

## What is CVE-2023-25571?

CVE-2023-25571 is a medium-severity cross-site scripting vulnerability in backstage, published on 14 Feb 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Backstage is an open platform for building developer portals. `@backstage/catalog-model` prior to version 1.2.0, `@backstage/core-components` prior to 0.12.4, and `@backstage/plugin-catalog-backend` prior to 1.7.2 are affected by a cross-site scripting vulnerability. This vulnerability allows a malicious actor with access to add or modify content in an instance of the Backstage software catalog to inject script URLs in the entities stored in the catalog. If users of the catalog then click on said URLs, that can lead to an XSS attack.

This vulnerability has been patched in both the frontend and backend implementations. The default `Link` component from `@backstage/core-components` version 1.2.0 and greater will now reject `javascript:` URLs, and there is a global override of `window.open` to do the same. In addition, the catalog model v0.12.4 and greater as well as the catalog backend v1.7.2 and greater now has additional validation built in that prevents `javascript:` URLs in known annotations. As a workaround, the general practice of limiting access to modifying catalog content and requiring code reviews greatly help mitigate this vulnerability.

Weakness: CWE-84 (Improper Neutralization of Encoded URI Schemes in a Web Page), CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2023-25571?

6 open source packages ship an affected version, including @backstage/catalog-model, @backstage/core-components and @backstage/plugin-catalog-backend. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@backstage/catalog-model` | npm | All versions | 1.2.0 |
| `@backstage/catalog-model` | npm | All versions | 1.2.0 |
| `@backstage/core-components` | npm | All versions | 0.12.4 |
| `@backstage/core-components` | npm | All versions | 0.12.4 |
| `@backstage/plugin-catalog-backend` | npm | All versions | 1.7.2 |
| `@backstage/plugin-catalog-backend` | npm | All versions | 1.7.2 |

Products: Linuxfoundation Backstage Catalog-Model, Linuxfoundation Backstage Core-Components, Linuxfoundation Backstage Plugin-Catalog-Backend.

## How do I fix CVE-2023-25571?

Upgrade @backstage/catalog-model to 1.2.0 or later.

## Is CVE-2023-25571 being exploited?

There is no known exploitation of CVE-2023-25571 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-25571 and fix it if it is affected.

What it is: CVE-2023-25571 is a medium-severity cross-site scripting vulnerability in backstage, published on 14 Feb 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-25571 in the wild and no public exploit code.

Affected packages and fixed versions:
- @backstage/catalog-model (npm): affected all versions; fixed in 1.2.0
- @backstage/catalog-model (npm): affected all versions; fixed in 1.2.0
- @backstage/core-components (npm): affected all versions; fixed in 0.12.4
- @backstage/core-components (npm): affected all versions; fixed in 0.12.4
- @backstage/plugin-catalog-backend (npm): affected all versions; fixed in 1.7.2
- @backstage/plugin-catalog-backend (npm): affected all versions; fixed in 1.7.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-25571/ (Markdown: https://insights.sbomify.com/CVE-2023-25571/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-25571
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-25571
- OSV: https://osv.dev/vulnerability/CVE-2023-25571

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-25571/
Summaries are generated and may contain mistakes; the official description above is the record.
