# CVE-2023-25572: React-Admin vulnerable to Cross-Site-Scripting attack on `<RichTextField>`

> Attackers can execute arbitrary scripts in browsers via unsanitized HTML in react-admin RichTextField components.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 13 Feb 2023
- **Updated:** 10 Mar 2025
- **Also known as:** GHSA-5jcr-82fh-339v

## What is CVE-2023-25572?

CVE-2023-25572 is a medium-severity cross-site scripting vulnerability in marmelab react-admin, published on 13 Feb 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

react-admin is a frontend framework for building browser applications on top of REST/GraphQL APIs. react-admin prior to versions 3.19.12 and 4.7.6, along with ra-ui-materialui prior to 3.19.12 and 4.7.6, are vulnerable to cross-site scripting. All React applications built with react-admin and using the `<RichTextField>` are affected. `<RichTextField>` outputs the field value using `dangerouslySetInnerHTML` without client-side sanitization. If the data isn't sanitized server-side, this opens a possible cross-site scripting (XSS) attack. Versions 3.19.12 and 4.7.6 now use `DOMPurify` to escape the HTML before outputting it with React and `dangerouslySetInnerHTML`. Users who already sanitize HTML data server-side do not need to upgrade. As a workaround, users may replace the `<RichTextField>` by a custom field doing sanitization by hand.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2023-25572?

8 open source packages ship an affected version, including react-admin and ra-ui-materialui. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `react-admin` | npm | All versions | 3.19.12 |
| `react-admin` | npm | All versions | 3.19.12 |
| `react-admin` | npm | From 4.0.0 | 4.7.6 |
| `react-admin` | npm | From 4.0.0 | 4.7.6 |
| `ra-ui-materialui` | npm | All versions | 3.19.12 |
| `ra-ui-materialui` | npm | All versions | 3.19.12 |
| `ra-ui-materialui` | npm | From 4.0.0 | 4.7.6 |
| `ra-ui-materialui` | npm | From 4.0.0 | 4.7.6 |

Products: Marmelab Ra-Ui-Materialui, Marmelab React-Admin.

## How do I fix CVE-2023-25572?

Upgrade react-admin to a fixed version for your release line: 3.19.12 or 4.7.6.

## Is CVE-2023-25572 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-25572 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-25572 and fix it if it is affected.

What it is: CVE-2023-25572 is a medium-severity cross-site scripting vulnerability in marmelab react-admin, published on 13 Feb 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-25572 exists.

Affected packages and fixed versions:
- react-admin (npm): affected all versions; fixed in 3.19.12
- react-admin (npm): affected all versions; fixed in 3.19.12
- react-admin (npm): affected from 4.0.0; fixed in 4.7.6
- react-admin (npm): affected from 4.0.0; fixed in 4.7.6
- ra-ui-materialui (npm): affected all versions; fixed in 3.19.12
- ra-ui-materialui (npm): affected all versions; fixed in 3.19.12
- ra-ui-materialui (npm): affected from 4.0.0; fixed in 4.7.6
- ra-ui-materialui (npm): affected from 4.0.0; fixed in 4.7.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-25572/ (Markdown: https://insights.sbomify.com/CVE-2023-25572/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-25572
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-25572
- OSV: https://osv.dev/vulnerability/CVE-2023-25572

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-25572/
Summaries are generated and may contain mistakes; the official description above is the record.
