{"answers":{"affected":"3 open source packages ship an affected version, including jupyterhub-ltiauthenticator. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-25574 in the wild and no public exploit code.","fix":"Upgrade jupyterhub-ltiauthenticator to 1.4.0 or later.","what":"CVE-2023-25574 is a critical authentication bypass vulnerability in jupyterhub ltiauthenticator, published on 25 Feb 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-25574 and fix it if it is affected.\n\nWhat it is: CVE-2023-25574 is a critical authentication bypass vulnerability in jupyterhub ltiauthenticator, published on 25 Feb 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-25574 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- jupyterhub-ltiauthenticator (PyPI): affected all versions up to 1.3.0; no fix listed\n- jupyterhub-ltiauthenticator (PyPI): affected from 1.3.0; fixed in 1.4.0\n- jupyterhub-ltiauthenticator (PyPI): affected from 1.3.0; fixed in 1.4.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-25574/ (Markdown: https://insights.sbomify.com/CVE-2023-25574/index.md)","id":"CVE-2023-25574","markdown":"https://insights.sbomify.com/CVE-2023-25574/index.md","name":"CVE-2023-25574","record":{"aliases":["GHSA-mcgx-2gcr-p3hp","PYSEC-2025-120"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["account_takeover","security_bypass"],"network_reachable":"yes","non_default_config":true,"product_category":"JupyterHub LTI authenticator","requires_auth":"none","summary":"Attackers can forge LTI requests to bypass authentication in JupyterHub if the LTI13Authenticator is configured, allowing unauthorized access.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"lti_jupyterhub_authenticator","vendor":"jupyter"}],"cvss":{"score":10,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-347","name":"Improper Verification of Cryptographic Signature"}],"description":"`jupyterhub-ltiauthenticator` is a JupyterHub authenticator for learning tools interoperability (LTI). LTI13Authenticator that was introduced in `jupyterhub-ltiauthenticator` 1.3.0 wasn't validating JWT signatures. This is believed to allow the LTI13Authenticator to authorize a forged request. Only users that has configured a JupyterHub installation to use the authenticator class `LTI13Authenticator` are affected. `jupyterhub-ltiauthenticator` version 1.4.0 removes LTI13Authenticator to address the issue. No known workarounds are available.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"JupyterHub's LTI13Authenticator: JWT signature not validated","id":"CVE-2023-25574","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"auth_bypass","year":"2023"},"n_packages":3,"n_references":3,"next":{"headline":"Secured properties in API Platform Core may be accessible within collections","id":"CVE-2023-25575"},"packages":[{"ecosystem":"PyPI","fixed":[],"introduced":["0"],"last_affected":["1.3.0"],"package":"jupyterhub-ltiauthenticator","purl":"pkg:pypi/jupyterhub-ltiauthenticator","source":"PYSEC-2025-120"},{"ecosystem":"PyPI","fixed":["1.4.0"],"introduced":["1.3.0"],"last_affected":[],"package":"jupyterhub-ltiauthenticator","purl":null,"source":"GHSA-mcgx-2gcr-p3hp"},{"ecosystem":"PyPI","fixed":["1.4.0"],"introduced":["1.3.0"],"last_affected":[],"package":"jupyterhub-ltiauthenticator","purl":"pkg:pypi/jupyterhub-ltiauthenticator","source":"GHSA-mcgx-2gcr-p3hp"}],"prev":{"headline":"Improper access control to download file in metersphere","id":"CVE-2023-25573"},"products":["ltiauthenticator"],"published":"2025-02-25","related":[{"cvss_score":5.9,"headline":"LTI JupyterHub Authenticator: Unbounded Memory Growth via Nonce Storage (Denial of Service)","id":"CVE-2026-34052","kev_date_added":null,"published":"2026-04-03"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-02-25","vendors":["jupyterhub"]},"summary":"Attackers can forge LTI requests to bypass authentication in JupyterHub if the LTI13Authenticator is configured, allowing unauthorized access.","url":"https://insights.sbomify.com/CVE-2023-25574/"}