# CVE-2023-25574: JupyterHub's LTI13Authenticator: JWT signature not validated

> Attackers can forge LTI requests to bypass authentication in JupyterHub if the LTI13Authenticator is configured, allowing unauthorized access.

- **Severity:** Critical 10.0 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Feb 2025
- **Updated:** 25 Feb 2025
- **Also known as:** GHSA-mcgx-2gcr-p3hp, PYSEC-2025-120

## What is CVE-2023-25574?

CVE-2023-25574 is a critical authentication bypass vulnerability in jupyterhub ltiauthenticator, published on 25 Feb 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

`jupyterhub-ltiauthenticator` is a JupyterHub authenticator for learning tools interoperability (LTI). LTI13Authenticator that was introduced in `jupyterhub-ltiauthenticator` 1.3.0 wasn't validating JWT signatures. This is believed to allow the LTI13Authenticator to authorize a forged request. Only users that has configured a JupyterHub installation to use the authenticator class `LTI13Authenticator` are affected. `jupyterhub-ltiauthenticator` version 1.4.0 removes LTI13Authenticator to address the issue. No known workarounds are available.

Weakness: CWE-347 (Improper Verification of Cryptographic Signature)

## Which versions are affected by CVE-2023-25574?

3 open source packages ship an affected version, including jupyterhub-ltiauthenticator. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `jupyterhub-ltiauthenticator` | PyPI | All versions to 1.3.0 | None |
| `jupyterhub-ltiauthenticator` | PyPI | From 1.3.0 | 1.4.0 |
| `jupyterhub-ltiauthenticator` | PyPI | From 1.3.0 | 1.4.0 |

Products: Jupyter Lti Jupyterhub Authenticator.

## How do I fix CVE-2023-25574?

Upgrade jupyterhub-ltiauthenticator to 1.4.0 or later.

## Is CVE-2023-25574 being exploited?

There is no known exploitation of CVE-2023-25574 in the wild and no public exploit code.

## Other vulnerabilities in jupyterhub ltiauthenticator

- [CVE-2026-34052](https://insights.sbomify.com/CVE-2026-34052/): LTI JupyterHub Authenticator: Unbounded Memory Growth via Nonce Storage (Denial of Service) (medium 5.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-25574 and fix it if it is affected.

What it is: CVE-2023-25574 is a critical authentication bypass vulnerability in jupyterhub ltiauthenticator, published on 25 Feb 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-25574 in the wild and no public exploit code.

Affected packages and fixed versions:
- jupyterhub-ltiauthenticator (PyPI): affected all versions up to 1.3.0; no fix listed
- jupyterhub-ltiauthenticator (PyPI): affected from 1.3.0; fixed in 1.4.0
- jupyterhub-ltiauthenticator (PyPI): affected from 1.3.0; fixed in 1.4.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-25574/ (Markdown: https://insights.sbomify.com/CVE-2023-25574/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-25574
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-25574
- OSV: https://osv.dev/vulnerability/CVE-2023-25574

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-25574/
Summaries are generated and may contain mistakes; the official description above is the record.
