CVE-2023-25576 @fastify/multipart vulnerable to DoS due to unlimited number of parts
Attackers can cause denial of service by sending unlimited multipart parts to applications using the @fastify/multipart library.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2023-25576?
CVE-2023-25576 is a high-severity denial of service vulnerability in fastify-multipart, published on 14 Feb 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
@fastify/multipart is a Fastify plugin to parse the multipart content-type. Prior to versions 7.4.1 and 6.0.1, @fastify/multipart may experience denial of service due to a number of situations in which an unlimited number of parts are accepted. This includes the multipart body parser accepting an unlimited number of file parts, the multipart body parser accepting an unlimited number of field parts, and the multipart body parser accepting an unlimited number of empty parts as field parts. This is fixed in v7.4.1 (for Fastify v4.x) and v6.0.1 (for Fastify v3.x). There are no known workarounds.
Weakness: CWE-770
Which versions are affected by CVE-2023-25576?
4 open source packages ship an affected version, including @fastify/multipart. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
@fastify/multipart npm | All versions | 6.0.1 |
@fastify/multipart npm | All versions | 6.0.1 |
@fastify/multipart npm | From 7.0.0 | 7.4.1 |
@fastify/multipart npm | From 7.0.0 | 7.4.1 |
Products include Fastify Fastify-Multipart.
How do I fix CVE-2023-25576?
Upgrade @fastify/multipart to a fixed version for your release line: 6.0.1 or 7.4.1.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2023-25576 being exploited?
There is no known exploitation of CVE-2023-25576 in the wild and no public exploit code.
Other vulnerabilities in fastify-multipart
- CVE-2026-18549 @fastify/multipart vulnerable to Denial of Service via aborted upload after fileSize limit
- CVE-2026-19474 @fastify/multipart vulnerable to Denial of Service via temporary file leak on aborted upload
- CVE-2021-23597 Denial of Service (DoS)
- CVE-2020-8136 Uncontrolled Resource Consumption in fastify-multipart
Sources
Also known as GHSA-hpp2-2cr5-pf6g.