# CVE-2023-25576: @fastify/multipart vulnerable to DoS due to unlimited number of parts

> Attackers can cause denial of service by sending unlimited multipart parts to applications using the @fastify/multipart library.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Feb 2023
- **Updated:** 10 Mar 2025
- **Also known as:** GHSA-hpp2-2cr5-pf6g

## What is CVE-2023-25576?

CVE-2023-25576 is a high-severity denial of service vulnerability in fastify-multipart, published on 14 Feb 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

@fastify/multipart is a Fastify plugin to parse the multipart content-type. Prior to versions 7.4.1 and 6.0.1, @fastify/multipart may experience denial of service due to a number of situations in which an unlimited number of parts are accepted. This includes the multipart body parser accepting an unlimited number of file parts, the multipart body parser accepting an unlimited number of field parts, and the multipart body parser accepting an unlimited number of empty parts as field parts. This is fixed in v7.4.1 (for Fastify v4.x) and v6.0.1 (for Fastify v3.x). There are no known workarounds.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2023-25576?

4 open source packages ship an affected version, including @fastify/multipart. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@fastify/multipart` | npm | All versions | 6.0.1 |
| `@fastify/multipart` | npm | All versions | 6.0.1 |
| `@fastify/multipart` | npm | From 7.0.0 | 7.4.1 |
| `@fastify/multipart` | npm | From 7.0.0 | 7.4.1 |

Products: Fastify Fastify-Multipart.

## How do I fix CVE-2023-25576?

Upgrade @fastify/multipart to a fixed version for your release line: 6.0.1 or 7.4.1.

## Is CVE-2023-25576 being exploited?

There is no known exploitation of CVE-2023-25576 in the wild and no public exploit code.

## Other vulnerabilities in fastify-multipart

- [CVE-2026-18549](https://insights.sbomify.com/CVE-2026-18549/): @fastify/multipart vulnerable to Denial of Service via aborted upload after fileSize limit (high 7.5)
- [CVE-2026-19474](https://insights.sbomify.com/CVE-2026-19474/): @fastify/multipart vulnerable to Denial of Service via temporary file leak on aborted upload (high 7.5)
- [CVE-2021-23597](https://insights.sbomify.com/CVE-2021-23597/): Denial of Service (DoS) (high 7.5)
- [CVE-2020-8136](https://insights.sbomify.com/CVE-2020-8136/): Uncontrolled Resource Consumption in fastify-multipart (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-25576 and fix it if it is affected.

What it is: CVE-2023-25576 is a high-severity denial of service vulnerability in fastify-multipart, published on 14 Feb 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-25576 in the wild and no public exploit code.

Affected packages and fixed versions:
- @fastify/multipart (npm): affected all versions; fixed in 6.0.1
- @fastify/multipart (npm): affected all versions; fixed in 6.0.1
- @fastify/multipart (npm): affected from 7.0.0; fixed in 7.4.1
- @fastify/multipart (npm): affected from 7.0.0; fixed in 7.4.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-25576/ (Markdown: https://insights.sbomify.com/CVE-2023-25576/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-25576
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-25576
- OSV: https://osv.dev/vulnerability/CVE-2023-25576

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-25576/
Summaries are generated and may contain mistakes; the official description above is the record.
