# CVE-2023-25578: Starlite DoS vulnerability when parsing multipart request body

> An attacker can cause denial of service in Starlite applications by sending excessive multipart requests, consuming CPU and memory resources.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Feb 2023
- **Updated:** 10 Mar 2025
- **Also known as:** GHSA-p24m-863f-fm6q, PYSEC-2023-49

## What is CVE-2023-25578?

CVE-2023-25578 is a high-severity denial of service vulnerability in starlite-api starlite, published on 15 Feb 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Starlite is an Asynchronous Server Gateway Interface (ASGI) framework. Prior to version 1.5.2, the request body parsing in `starlite` allows a potentially unauthenticated attacker to consume a large amount of CPU time and RAM. The multipart body parser processes an unlimited number of file parts and an unlimited number of field parts. This is a remote, potentially unauthenticated Denial of Service vulnerability. This vulnerability affects applications with a request handler that accepts a `Body(media_type=RequestEncodingType.MULTI_PART)`. The large amount of CPU time required for processing requests can block all available worker processes and significantly delay or slow down the processing of legitimate user requests. The large amount of RAM accumulated while processing requests can lead to Out-Of-Memory kills. Complete DoS is achievable by sending many concurrent multipart requests in a loop. Version 1.51.2 contains a patch for this issue.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2023-25578?

3 open source packages ship an affected version, including starlite. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `starlite` | PyPI | All versions | 1.51.2 |
| `starlite` | PyPI | All versions | 1.51.2 |
| `starlite` | PyPI | All versions | 1.51.2 |

Products: Starliteproject Starlite.

## How do I fix CVE-2023-25578?

Upgrade starlite to 1.51.2 or later.

## Is CVE-2023-25578 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-25578 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-25578 and fix it if it is affected.

What it is: CVE-2023-25578 is a high-severity denial of service vulnerability in starlite-api starlite, published on 15 Feb 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-25578 exists.

Affected packages and fixed versions:
- starlite (PyPI): affected all versions; fixed in 1.51.2
- starlite (PyPI): affected all versions; fixed in 1.51.2
- starlite (PyPI): affected all versions; fixed in 1.51.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-25578/ (Markdown: https://insights.sbomify.com/CVE-2023-25578/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-25578
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-25578
- OSV: https://osv.dev/vulnerability/CVE-2023-25578

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-25578/
Summaries are generated and may contain mistakes; the official description above is the record.
