# CVE-2023-25613: LDAP Injection Vulnerability in Apache Kerby


- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 20 Feb 2023
- **Updated:** 2 Aug 2024
- **Also known as:** CLEANSTART-2026-AK44750, GHSA-337f-xr2x-6fcf

## What is CVE-2023-25613?

CVE-2023-25613 is a critical vulnerability in Apache Kerby LDAP Backend, published on 20 Feb 2023. 

### Official description

An LDAP Injection vulnerability exists in the LdapIdentityBackend of Apache Kerby before 2.0.3.

Weakness: CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component)

## Which versions are affected by CVE-2023-25613?

2 open source packages ship an affected version, including org.apache.kerby:ldap-backend. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.kerby:ldap-backend` | Maven | All versions | 2.0.3 |
| `org.apache.kerby:ldap-backend` | Maven | All versions | 2.0.3 |

Products: Apache Kerby Ldap Backend.

## How do I fix CVE-2023-25613?

Upgrade org.apache.kerby:ldap-backend to 2.0.3 or later.

## Is CVE-2023-25613 being exploited?

There is no known exploitation of CVE-2023-25613 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-25613 and fix it if it is affected.

What it is: CVE-2023-25613 is a critical vulnerability in Apache Kerby LDAP Backend, published on 20 Feb 2023. 
Exploitation: There is no known exploitation of CVE-2023-25613 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.kerby:ldap-backend (Maven): affected all versions; fixed in 2.0.3
- org.apache.kerby:ldap-backend (Maven): affected all versions; fixed in 2.0.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-25613/ (Markdown: https://insights.sbomify.com/CVE-2023-25613/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-25613
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-25613
- OSV: https://osv.dev/vulnerability/CVE-2023-25613

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-25613/
Summaries are generated and may contain mistakes; the official description above is the record.
