{"answers":{"affected":"2 open source packages ship an affected version, including org.apache.sling:org.apache.sling.i18n. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-25621 in the wild and no public exploit code.","fix":"Upgrade org.apache.sling:org.apache.sling.i18n to 2.6.2 or later.","what":"CVE-2023-25621 is a medium-severity vulnerability in Apache Sling, published on 23 Feb 2023. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-25621 and fix it if it is affected.\n\nWhat it is: CVE-2023-25621 is a medium-severity vulnerability in Apache Sling, published on 23 Feb 2023. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-25621 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.apache.sling:org.apache.sling.i18n (Maven): affected all versions; fixed in 2.6.2\n- org.apache.sling:org.apache.sling.i18n (Maven): affected all versions; fixed in 2.6.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-25621/ (Markdown: https://insights.sbomify.com/CVE-2023-25621/index.md)","id":"CVE-2023-25621","markdown":"https://insights.sbomify.com/CVE-2023-25621/index.md","name":"CVE-2023-25621","record":{"aliases":["GHSA-mrpv-5pmr-p92h"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["privilege_escalation","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Apache Sling i18n module","requires_auth":"low_privilege","summary":"Content authors can modify global i18n dictionaries to alter UI text, potentially misleading users or bypassing security controls.","user_interaction":"not_required","vuln_class":"privilege_escalation"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"sling_i18n","vendor":"apache"}],"cvss":{"score":6.5,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N","version":"3.1"},"cwes":[],"description":"Privilege Escalation vulnerability in Apache Software Foundation Apache Sling.\nAny content author is able to create i18n dictionaries in the repository in a location the author has write access to. As these translations are used across the whole product, it allows an author to change any text or dialog in the product. For example an attacker might fool someone by changing the text on a delete button to \"Info\".\nThis issue affects the i18n module of Apache Sling up to version 2.5.18. Version 2.6.2 and higher limit by default i18m dictionaries to certain paths in the repository (/libs and /apps).\n\nUsers of the module are advised to update to version 2.6.2 or higher, check the configuration for resource loading and then adjust the access permissions for the configured path accordingly.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache Sling does not allow to handle i18n content in a secure way","id":"CVE-2023-25621","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"privilege_escalation","year":"2023"},"n_packages":2,"n_references":1,"next":{"headline":"Security feature bypass in NAVER Whale browser","id":"CVE-2023-25632"},"packages":[{"ecosystem":"Maven","fixed":["2.6.2"],"introduced":["0"],"last_affected":[],"package":"org.apache.sling:org.apache.sling.i18n","purl":null,"source":"GHSA-mrpv-5pmr-p92h"},{"ecosystem":"Maven","fixed":["2.6.2"],"introduced":["0"],"last_affected":[],"package":"org.apache.sling:org.apache.sling.i18n","purl":"pkg:maven/org.apache.sling/org.apache.sling.i18n","source":"GHSA-mrpv-5pmr-p92h"}],"prev":{"headline":"Denial of service in Legacy Modicon Premium CPUs (TSXP57*)","id":"CVE-2023-25620"},"products":["Apache Sling"],"published":"2023-02-23","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-03-18","vendors":["Apache Software Foundation"]},"summary":"Content authors can modify global i18n dictionaries to alter UI text, potentially misleading users or bypassing security controls.","url":"https://insights.sbomify.com/CVE-2023-25621/"}