# CVE-2023-25621: Apache Sling does not allow to handle i18n content in a secure way

> Content authors can modify global i18n dictionaries to alter UI text, potentially misleading users or bypassing security controls.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Feb 2023
- **Updated:** 18 Mar 2025
- **Also known as:** GHSA-mrpv-5pmr-p92h

## What is CVE-2023-25621?

CVE-2023-25621 is a medium-severity vulnerability in Apache Sling, published on 23 Feb 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Privilege Escalation vulnerability in Apache Software Foundation Apache Sling.
Any content author is able to create i18n dictionaries in the repository in a location the author has write access to. As these translations are used across the whole product, it allows an author to change any text or dialog in the product. For example an attacker might fool someone by changing the text on a delete button to "Info".
This issue affects the i18n module of Apache Sling up to version 2.5.18. Version 2.6.2 and higher limit by default i18m dictionaries to certain paths in the repository (/libs and /apps).

Users of the module are advised to update to version 2.6.2 or higher, check the configuration for resource loading and then adjust the access permissions for the configured path accordingly.

## Which versions are affected by CVE-2023-25621?

2 open source packages ship an affected version, including org.apache.sling:org.apache.sling.i18n. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.sling:org.apache.sling.i18n` | Maven | All versions | 2.6.2 |
| `org.apache.sling:org.apache.sling.i18n` | Maven | All versions | 2.6.2 |

Products: Apache Sling I18n.

## How do I fix CVE-2023-25621?

Upgrade org.apache.sling:org.apache.sling.i18n to 2.6.2 or later.

## Is CVE-2023-25621 being exploited?

There is no known exploitation of CVE-2023-25621 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-25621 and fix it if it is affected.

What it is: CVE-2023-25621 is a medium-severity vulnerability in Apache Sling, published on 23 Feb 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-25621 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.sling:org.apache.sling.i18n (Maven): affected all versions; fixed in 2.6.2
- org.apache.sling:org.apache.sling.i18n (Maven): affected all versions; fixed in 2.6.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-25621/ (Markdown: https://insights.sbomify.com/CVE-2023-25621/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-25621
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-25621
- OSV: https://osv.dev/vulnerability/CVE-2023-25621

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-25621/
Summaries are generated and may contain mistakes; the official description above is the record.
