{"answers":{"affected":"2 open source packages ship an affected version, including node-jose. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-25653 in the wild and no public exploit code.","fix":"Upgrade node-jose to 2.2.0 or later.","what":"CVE-2023-25653 is a high-severity denial of service vulnerability in cisco node-jose, published on 16 Feb 2023. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-25653 and fix it if it is affected.\n\nWhat it is: CVE-2023-25653 is a high-severity denial of service vulnerability in cisco node-jose, published on 16 Feb 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-25653 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- node-jose (npm): affected all versions; fixed in 2.2.0\n- node-jose (npm): affected all versions; fixed in 2.2.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-25653/ (Markdown: https://insights.sbomify.com/CVE-2023-25653/index.md)","id":"CVE-2023-25653","markdown":"https://insights.sbomify.com/CVE-2023-25653/index.md","name":"CVE-2023-25653","record":{"aliases":["GHSA-5h4j-qrvg-9xhw"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":true,"product_category":"JavaScript JOSE library","requires_auth":"none","summary":"Attackers can cause a denial of service via infinite loops in ECC operations when using the non-default fallback crypto backend.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"node-jose","vendor":"cisco"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-835","name":"Loop with Unreachable Exit Condition"}],"description":"node-jose is a JavaScript implementation of the JSON Object Signing and Encryption (JOSE) for web browsers and node.js-based servers. Prior to version 2.2.0, when using the non-default \"fallback\" crypto back-end, ECC operations in `node-jose` can trigger a Denial-of-Service (DoS) condition, due to a possible infinite loop in an internal calculation.  For some ECC operations, this condition is triggered randomly; for others, it can be triggered by malicious input. The issue has been patched in version 2.2.0. Since this issue is only present in the \"fallback\" crypto implementation, it can be avoided by ensuring that either WebCrypto or the Node `crypto` module is available in the JS environment where `node-jose` is being run.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Improper calculations in ECC implementation can trigger a Denial-of-Service (DoS)","id":"CVE-2023-25653","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2023"},"n_packages":2,"n_references":2,"next":{"headline":"baserCMS File Uploader Remote Code Execution (RCE) vulnerability","id":"CVE-2023-25654"},"packages":[{"ecosystem":"npm","fixed":["2.2.0"],"introduced":["0"],"last_affected":[],"package":"node-jose","purl":null,"source":"GHSA-5h4j-qrvg-9xhw"},{"ecosystem":"npm","fixed":["2.2.0"],"introduced":["0"],"last_affected":[],"package":"node-jose","purl":"pkg:npm/node-jose","source":"GHSA-5h4j-qrvg-9xhw"}],"prev":{"headline":"\"git apply --reject\" partially-controlled arbitrary file write","id":"CVE-2023-25652"},"products":["node-jose"],"published":"2023-02-16","related":[{"cvss_score":7.5,"headline":"Cisco node-jose improper validation of JWT signature","id":"CVE-2018-0114","kev_date_added":null,"published":"2018-01-04"},{"cvss_score":5.9,"headline":"Invalid Curve Attack in node-jose","id":"CVE-2017-16007","kev_date_added":null,"published":"2018-06-04"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-03-10","vendors":["cisco"]},"summary":"Attackers can cause a denial of service via infinite loops in ECC operations when using the non-default fallback crypto backend.","url":"https://insights.sbomify.com/CVE-2023-25653/"}