CVE-2023-25662 TensorFlow vulnerable to integer overflow in EditDistance

High 7.5 Published Updated

An integer overflow in TensorFlow's EditDistance operation can lead to denial of service, requiring users to upgrade to patched versions.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2023-25662?

CVE-2023-25662 is a high-severity vulnerability in Google Tensorflow, published on 24 Mar 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

TensorFlow is an open source platform for machine learning. Versions prior to 2.12.0 and 2.11.1 are vulnerable to integer overflow in EditDistance. A fix is included in TensorFlow version 2.12.0 and version 2.11.1.

Weakness: CWE-190

Which versions are affected by CVE-2023-25662?

10 open source packages ship an affected version, including tensorflow, tensorflow-cpu and tensorflow-gpu. It affects 1 product.

PackageAffectedFixed in
tensorflow BitnamiAll versions2.12.0
tensorflow PyPIAll versions2.11.1
tensorflow PyPIAll versions2.11.1
tensorflow PyPIAll versions2.11.1
tensorflow-cpu PyPIAll versions2.11.1
tensorflow-cpu PyPIAll versions2.11.1
4 more packages
tensorflow-cpu PyPIAll versions2.11.1
tensorflow-gpu PyPIAll versions2.11.1
tensorflow-gpu PyPIAll versions2.11.1
tensorflow-gpu PyPIAll versions2.11.1

Products include Google Tensorflow.

How do I fix CVE-2023-25662?

Upgrade tensorflow to a fixed version for your release line: 2.12.0 or 2.11.1.

Is CVE-2023-25662 being exploited?

There is no known exploitation of CVE-2023-25662 in the wild and no public exploit code.

All Google Tensorflow vulnerabilities

Sources

Also known as AZL-31209, AZL-35307, BIT-tensorflow-2023-25662, GHSA-7jvm-xxmr-v5cw, PYSEC-2026-1958, PYSEC-2026-3130 and 1 more.

Is CVE-2023-25662 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free