CVE-2023-25664 TensorFlow vulnerable to Heap Buffer Overflow in AvgPoolGrad

High 7.5 Published Updated

A heap buffer overflow in TensorFlow's AvgPoolGrad operation allows attackers to execute arbitrary code or cause a denial of service.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2023-25664?

CVE-2023-25664 is a high-severity memory corruption vulnerability in Google Tensorflow, published on 24 Mar 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

TensorFlow is an open source platform for machine learning. Prior to versions 2.12.0 and 2.11.1, there is a heap buffer overflow in TAvgPoolGrad. A fix is included in TensorFlow 2.12.0 and 2.11.1.

Weakness: CWE-122, CWE-120

Which versions are affected by CVE-2023-25664?

7 open source packages ship an affected version, including tensorflow and tensorflow-cpu. It affects 1 product.

PackageAffectedFixed in
tensorflow BitnamiAll versions2.12.0
tensorflow PyPIAll versions2.11.1
tensorflow PyPIAll versions2.11.1
tensorflow PyPIAll versions2.11.1
tensorflow-cpu PyPIAll versions2.11.1
tensorflow-cpu PyPIAll versions2.11.1
1 more packages
tensorflow-cpu PyPIAll versions2.11.1

Products include Google Tensorflow.

How do I fix CVE-2023-25664?

Upgrade tensorflow to a fixed version for your release line: 2.12.0 or 2.11.1.

Upgrade to the fixed version. Memory-safe languages, compiler hardening and fuzzing prevent most new cases. More about Memory corruption.

Is CVE-2023-25664 being exploited?

There is no known exploitation of CVE-2023-25664 in the wild and no public exploit code.

All Google Tensorflow vulnerabilities

Sources

Also known as AZL-31211, AZL-35309, BIT-tensorflow-2023-25664, GHSA-6hg6-5c2q-7rcr, PYSEC-2026-1951, PYSEC-2026-3122.

Is CVE-2023-25664 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free