CVE-2023-25665 TensorFlow has Null Pointer Error in SparseSparseMaximum
An attacker can cause a denial of service by providing invalid sparse tensors to TensorFlow's SparseSparseMaximum operation, triggering a null pointer error.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2023-25665?
CVE-2023-25665 is a high-severity vulnerability in Google Tensorflow, published on 24 Mar 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
TensorFlow is an open source platform for machine learning. Prior to versions 2.12.0 and 2.11.1, when `SparseSparseMaximum` is given invalid sparse tensors as inputs, it can give a null pointer error. A fix is included in TensorFlow version 2.12 and version 2.11.1.
Weakness: CWE-476
Which versions are affected by CVE-2023-25665?
10 open source packages ship an affected version, including tensorflow, tensorflow-cpu and tensorflow-gpu. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
tensorflow Bitnami | All versions | 2.12.0 |
tensorflow PyPI | All versions | 2.11.1 |
tensorflow PyPI | All versions | 2.11.1 |
tensorflow PyPI | All versions | 2.11.1 |
tensorflow-cpu PyPI | All versions | 2.11.1 |
tensorflow-cpu PyPI | All versions | 2.11.1 |
4 more packages
tensorflow-cpu PyPI | All versions | 2.11.1 |
tensorflow-gpu PyPI | All versions | 2.11.1 |
tensorflow-gpu PyPI | All versions | 2.11.1 |
tensorflow-gpu PyPI | All versions | 2.11.1 |
Products include Google Tensorflow.
How do I fix CVE-2023-25665?
Upgrade tensorflow to a fixed version for your release line: 2.12.0 or 2.11.1.
Is CVE-2023-25665 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-25665 exists.
Other vulnerabilities in Google Tensorflow
- CVE-2023-25668 TensorFlow vulnerable to heap out-of-buffer read in the QuantizeAndDequantize operation
- CVE-2018-7575 Integer Overflow or Wraparound in Google TensorFlow
- CVE-2021-37678 Arbitrary code execution due to YAML deserialization
- CVE-2021-35958 Path traversal in n/a
- CVE-2020-15202 Integer truncation in Shard API usage
Sources
Also known as AZL-31216, AZL-35310, BIT-tensorflow-2023-25665, GHSA-558h-mq8x-7q9g, PYSEC-2026-1956, PYSEC-2026-3106 and 1 more.