CVE-2023-25668 TensorFlow vulnerable to heap out-of-buffer read in the QuantizeAndDequantize operation

Critical 9.8 Published Updated

Attackers can trigger a heap out-of-buffer read in TensorFlow's QuantizeAndDequantize operation, potentially causing crashes or remote code execution.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2023-25668?

CVE-2023-25668 is a critical memory corruption vulnerability in Google Tensorflow, published on 24 Mar 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

TensorFlow is an open source platform for machine learning. Attackers using Tensorflow prior to 2.12.0 or 2.11.1 can access heap memory which is not in the control of user, leading to a crash or remote code execution. The fix will be included in TensorFlow version 2.12.0 and will also cherrypick this commit on TensorFlow version 2.11.1.

Weakness: CWE-125, CWE-122

Which versions are affected by CVE-2023-25668?

10 open source packages ship an affected version, including tensorflow, tensorflow-cpu and tensorflow-gpu. It affects 1 product.

PackageAffectedFixed in
tensorflow BitnamiAll versions2.12.0
tensorflow PyPIAll versions2.11.1
tensorflow PyPIAll versions2.11.1
tensorflow PyPIAll versions2.11.1
tensorflow-cpu PyPIAll versions2.11.1
tensorflow-cpu PyPIAll versions2.11.1
4 more packages
tensorflow-cpu PyPIAll versions2.11.1
tensorflow-gpu PyPIAll versions2.11.1
tensorflow-gpu PyPIAll versions2.11.1
tensorflow-gpu PyPIAll versions2.11.1

Products include Google Tensorflow.

How do I fix CVE-2023-25668?

Upgrade tensorflow to a fixed version for your release line: 2.12.0 or 2.11.1.

Upgrade to the fixed version. Memory-safe languages, compiler hardening and fuzzing prevent most new cases. More about Memory corruption.

Is CVE-2023-25668 being exploited?

There is no known exploitation of CVE-2023-25668 in the wild and no public exploit code.

All Google Tensorflow vulnerabilities

Sources

Also known as AZL-31200, AZL-35313, BIT-tensorflow-2023-25668, GHSA-gw97-ff7c-9v96, PYSEC-2026-548, PYSEC-2026-549 and 1 more.

Is CVE-2023-25668 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free