CVE-2023-25674 TensorFlow has Null Pointer Error in RandomShuffle with XLA enable

High 7.5 Published Updated

Attackers can cause a denial of service via null pointer dereference in RandomShuffle when XLA is enabled in TensorFlow.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2023-25674?

CVE-2023-25674 is a high-severity vulnerability in Google Tensorflow, published on 24 Mar 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

TensorFlow is an open source machine learning platform. Versions prior to 2.12.0 and 2.11.1 have a null pointer error in RandomShuffle with XLA enabled. A fix is included in TensorFlow 2.12.0 and 2.11.1.

Weakness: CWE-476

Which versions are affected by CVE-2023-25674?

10 open source packages ship an affected version, including tensorflow, tensorflow-cpu and tensorflow-gpu. It affects 1 product.

PackageAffectedFixed in
tensorflow BitnamiAll versions2.12.0
tensorflow PyPIAll versions2.11.1
tensorflow PyPIAll versions2.11.1
tensorflow PyPIAll versions2.11.1
tensorflow-cpu PyPIAll versions2.11.1
tensorflow-cpu PyPIAll versions2.11.1
4 more packages
tensorflow-cpu PyPIAll versions2.11.1
tensorflow-gpu PyPIAll versions2.11.1
tensorflow-gpu PyPIAll versions2.11.1
tensorflow-gpu PyPIAll versions2.11.1

Products include Google Tensorflow.

How do I fix CVE-2023-25674?

Upgrade tensorflow to a fixed version for your release line: 2.12.0 or 2.11.1.

Is CVE-2023-25674 being exploited?

There is no known exploitation of CVE-2023-25674 in the wild and no public exploit code.

All Google Tensorflow vulnerabilities

Sources

Also known as AZL-31217, AZL-35319, BIT-tensorflow-2023-25674, GHSA-gf97-q72m-7579, PYSEC-2026-3189, PYSEC-2026-3330 and 1 more.

Is CVE-2023-25674 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free