{"answers":{"affected":"3 open source packages ship an affected version, including apache-airflow-providers-google. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-25692 in the wild and no public exploit code.","fix":"Upgrade apache-airflow-providers-google to 8.10.0 or later.","what":"CVE-2023-25692 is a high-severity denial of service vulnerability in Apache Airflow Google Provider, published on 24 Feb 2023. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-25692 and fix it if it is affected.\n\nWhat it is: CVE-2023-25692 is a high-severity denial of service vulnerability in Apache Airflow Google Provider, published on 24 Feb 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-25692 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- apache-airflow-providers-google (PyPI): affected all versions; fixed in 8.10.0\n- apache-airflow-providers-google (PyPI): affected all versions; fixed in 8.10.0\n- apache-airflow-providers-google (PyPI): affected all versions; fixed in 8.10.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-25692/ (Markdown: https://insights.sbomify.com/CVE-2023-25692/index.md)","id":"CVE-2023-25692","markdown":"https://insights.sbomify.com/CVE-2023-25692/index.md","name":"CVE-2023-25692","record":{"aliases":["GHSA-h8p2-8g72-qpgh","PYSEC-2026-774","ROOT-APP-PYPI-CVE-2023-25692"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Airflow Google Provider","requires_auth":"none","summary":"An improper input validation flaw in the Apache Airflow Google Provider allows attackers to cause a denial of service.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"apache-airflow-providers-google","vendor":"apache"}],"cvss":{"score":7.5,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"Improper Input Validation vulnerability in the Apache Airflow Google Provider.\n\nThis issue affects Apache Airflow Google Provider versions before 8.10.0.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache Airflow Google Provider: Google Cloud Sql Provider Denial Of Service","id":"CVE-2023-25692","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"denial_of_service","year":"2023"},"n_packages":3,"n_references":2,"next":{"headline":"Sqoop Apache Airflow Provider Remote Code Execution Vulnerability","id":"CVE-2023-25693"},"packages":[{"ecosystem":"PyPI","fixed":["8.10.0"],"introduced":["0"],"last_affected":[],"package":"apache-airflow-providers-google","purl":null,"source":"GHSA-h8p2-8g72-qpgh"},{"ecosystem":"PyPI","fixed":["8.10.0"],"introduced":["0"],"last_affected":[],"package":"apache-airflow-providers-google","purl":"pkg:pypi/apache-airflow-providers-google","source":"GHSA-h8p2-8g72-qpgh"},{"ecosystem":"PyPI","fixed":["8.10.0"],"introduced":["0"],"last_affected":[],"package":"apache-airflow-providers-google","purl":"pkg:pypi/apache-airflow-providers-google","source":"PYSEC-2026-774"}],"prev":{"headline":"Apache Airflow Google Provider: Google Cloud Sql Provider Remote Command Execution","id":"CVE-2023-25691"},"products":["Apache Airflow Google Provider"],"published":"2023-02-24","related":[{"cvss_score":9.8,"headline":"Apache Airflow Google Provider: Google Cloud Sql Provider Remote Command Execution","id":"CVE-2023-25691","kev_date_added":null,"published":"2023-02-24"},{"cvss_score":8.1,"headline":"Apache Airflow Google provider allows path traversal through GCS object names","id":"CVE-2026-49297","kev_date_added":null,"published":"2026-07-06"},{"cvss_score":8.1,"headline":"Apache Airflow providers-google's `ComputeEngineSSHHook` disables SSH host-key verification by default","id":"CVE-2026-45361","kev_date_added":null,"published":"2026-05-25"},{"cvss_score":6.5,"headline":"Missing authorization in Apache Airflow Google provider","id":"CVE-2026-68868","kev_date_added":null,"published":"2026-08-12"},{"cvss_score":4.3,"headline":"Apache Airflow Google provider: Google Drive query injection via unescaped file and folder names","id":"CVE-2026-81914","kev_date_added":null,"published":"2026-09-29"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-03-11","vendors":["Apache Software Foundation"]},"summary":"An improper input validation flaw in the Apache Airflow Google Provider allows attackers to cause a denial of service.","url":"https://insights.sbomify.com/CVE-2023-25692/"}