# CVE-2023-25692: Apache Airflow Google Provider: Google Cloud Sql Provider Denial Of Service

> An improper input validation flaw in the Apache Airflow Google Provider allows attackers to cause a denial of service.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Feb 2023
- **Updated:** 11 Mar 2025
- **Also known as:** GHSA-h8p2-8g72-qpgh, PYSEC-2026-774, ROOT-APP-PYPI-CVE-2023-25692

## What is CVE-2023-25692?

CVE-2023-25692 is a high-severity denial of service vulnerability in Apache Airflow Google Provider, published on 24 Feb 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Improper Input Validation vulnerability in the Apache Airflow Google Provider.

This issue affects Apache Airflow Google Provider versions before 8.10.0.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2023-25692?

3 open source packages ship an affected version, including apache-airflow-providers-google. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache-airflow-providers-google` | PyPI | All versions | 8.10.0 |
| `apache-airflow-providers-google` | PyPI | All versions | 8.10.0 |
| `apache-airflow-providers-google` | PyPI | All versions | 8.10.0 |

Products: Apache Apache-Airflow-Providers-Google.

## How do I fix CVE-2023-25692?

Upgrade apache-airflow-providers-google to 8.10.0 or later.

## Is CVE-2023-25692 being exploited?

There is no known exploitation of CVE-2023-25692 in the wild and no public exploit code.

## Other vulnerabilities in Apache Airflow Google Provider

- [CVE-2023-25691](https://insights.sbomify.com/CVE-2023-25691/): Apache Airflow Google Provider: Google Cloud Sql Provider Remote Command Execution (critical 9.8)
- [CVE-2026-49297](https://insights.sbomify.com/CVE-2026-49297/): Apache Airflow Google provider allows path traversal through GCS object names (high 8.1)
- [CVE-2026-45361](https://insights.sbomify.com/CVE-2026-45361/): Apache Airflow providers-google's `ComputeEngineSSHHook` disables SSH host-key verification by default (high 8.1)
- [CVE-2026-68868](https://insights.sbomify.com/CVE-2026-68868/): Missing authorization in Apache Airflow Google provider (medium 6.5)
- [CVE-2026-81914](https://insights.sbomify.com/CVE-2026-81914/): Apache Airflow Google provider: Google Drive query injection via unescaped file and folder names (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-25692 and fix it if it is affected.

What it is: CVE-2023-25692 is a high-severity denial of service vulnerability in Apache Airflow Google Provider, published on 24 Feb 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-25692 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache-airflow-providers-google (PyPI): affected all versions; fixed in 8.10.0
- apache-airflow-providers-google (PyPI): affected all versions; fixed in 8.10.0
- apache-airflow-providers-google (PyPI): affected all versions; fixed in 8.10.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-25692/ (Markdown: https://insights.sbomify.com/CVE-2023-25692/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-25692
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-25692
- OSV: https://osv.dev/vulnerability/CVE-2023-25692

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-25692/
Summaries are generated and may contain mistakes; the official description above is the record.
