{"answers":{"affected":"4 open source packages ship an affected version, including apache-airflow-providers-apache-sqoop and apache-airflow. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-25693 in the wild and no public exploit code.","fix":"Upgrade apache-airflow-providers-apache-sqoop to 3.1.1 or later.","what":"CVE-2023-25693 is a critical code injection vulnerability in Apache Airflow Sqoop Provider, published on 24 Feb 2023. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-25693 and fix it if it is affected.\n\nWhat it is: CVE-2023-25693 is a critical code injection vulnerability in Apache Airflow Sqoop Provider, published on 24 Feb 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-25693 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- apache-airflow-providers-apache-sqoop (PyPI): affected all versions; fixed in 3.1.1\n- apache-airflow-providers-apache-sqoop (PyPI): affected all versions; fixed in 3.1.1\n- apache-airflow-providers-apache-sqoop (PyPI): affected all versions; fixed in 3.1.1\n- apache-airflow (PyPI): affected all versions; fixed in 3.1.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-25693/ (Markdown: https://insights.sbomify.com/CVE-2023-25693/index.md)","id":"CVE-2023-25693","markdown":"https://insights.sbomify.com/CVE-2023-25693/index.md","name":"CVE-2023-25693","record":{"aliases":["GHSA-j69x-v4wc-3fpf","PYSEC-2023-314","PYSEC-2026-275"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Airflow Sqoop Provider","requires_auth":"none","summary":"Attackers can execute arbitrary code via improper input validation in the Apache Airflow Sqoop Provider.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"apache-airflow-providers-apache-sqoop","vendor":"apache"}],"cvss":{"score":9.8,"severity":"critical","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"Improper Input Validation vulnerability in the Apache Airflow Sqoop Provider.\n\nThis issue affects Apache Airflow Sqoop Provider versions before 3.1.1.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Sqoop Apache Airflow Provider Remote Code Execution Vulnerability","id":"CVE-2023-25693","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"code_injection","year":"2023"},"n_packages":4,"n_references":2,"next":{"headline":"DO NOT USE THIS CANDIDATE NUMBER.","id":"CVE-2023-25694"},"packages":[{"ecosystem":"PyPI","fixed":["3.1.1"],"introduced":["0"],"last_affected":[],"package":"apache-airflow","purl":"pkg:pypi/apache-airflow","source":"PYSEC-2023-314"},{"ecosystem":"PyPI","fixed":["3.1.1"],"introduced":["0"],"last_affected":[],"package":"apache-airflow-providers-apache-sqoop","purl":null,"source":"GHSA-j69x-v4wc-3fpf"},{"ecosystem":"PyPI","fixed":["3.1.1"],"introduced":["0"],"last_affected":[],"package":"apache-airflow-providers-apache-sqoop","purl":"pkg:pypi/apache-airflow-providers-apache-sqoop","source":"GHSA-j69x-v4wc-3fpf"},{"ecosystem":"PyPI","fixed":["3.1.1"],"introduced":["0"],"last_affected":[],"package":"apache-airflow-providers-apache-sqoop","purl":"pkg:pypi/apache-airflow-providers-apache-sqoop","source":"PYSEC-2026-275"}],"prev":{"headline":"Apache Airflow Google Provider: Google Cloud Sql Provider Denial Of Service","id":"CVE-2023-25692"},"products":["Apache Airflow Sqoop Provider"],"published":"2023-02-24","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-02-13","vendors":["Apache Software Foundation"]},"summary":"Attackers can execute arbitrary code via improper input validation in the Apache Airflow Sqoop Provider.","url":"https://insights.sbomify.com/CVE-2023-25693/"}