# CVE-2023-25696: Apache Airflow Hive Provider Beeline RCE

> Attackers can execute arbitrary code via improper input validation in the Apache Airflow Hive Provider Beeline integration.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Feb 2023
- **Updated:** 23 Oct 2024
- **Also known as:** GHSA-9mwf-mw74-9cv5, PYSEC-2026-272

## What is CVE-2023-25696?

CVE-2023-25696 is a critical command injection vulnerability in Apache Airflow Hive Provider, published on 24 Feb 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Improper Input Validation vulnerability in the Apache Airflow Hive Provider.

This issue affects Apache Airflow Hive Provider versions before 5.1.3.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2023-25696?

3 open source packages ship an affected version, including apache-airflow-providers-apache-hive. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache-airflow-providers-apache-hive` | PyPI | All versions | 5.1.3 |
| `apache-airflow-providers-apache-hive` | PyPI | All versions | 5.1.3 |
| `apache-airflow-providers-apache-hive` | PyPI | All versions | 5.1.3 |

Products: Apache Apache-Airflow-Providers-Apache-Hive.

## How do I fix CVE-2023-25696?

Upgrade apache-airflow-providers-apache-hive to 5.1.3 or later.

## Is CVE-2023-25696 being exploited?

There is no known exploitation of CVE-2023-25696 in the wild and no public exploit code.

## Other vulnerabilities in Apache Airflow Hive Provider

- [CVE-2023-35797](https://insights.sbomify.com/CVE-2023-35797/): Apache Airflow Hive Provider Beeline RCE with Principal (critical 9.8)
- [CVE-2022-46421](https://insights.sbomify.com/CVE-2022-46421/): Apache Airflow Hive Provider: Hive Provider RCE vulnerability with hive_cli_params (critical 9.8)
- [CVE-2023-37415](https://insights.sbomify.com/CVE-2023-37415/): Apache Airflow Apache Hive Provider: Improper Input Validation in Hive Provider with proxy_user (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-25696 and fix it if it is affected.

What it is: CVE-2023-25696 is a critical command injection vulnerability in Apache Airflow Hive Provider, published on 24 Feb 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-25696 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache-airflow-providers-apache-hive (PyPI): affected all versions; fixed in 5.1.3
- apache-airflow-providers-apache-hive (PyPI): affected all versions; fixed in 5.1.3
- apache-airflow-providers-apache-hive (PyPI): affected all versions; fixed in 5.1.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-25696/ (Markdown: https://insights.sbomify.com/CVE-2023-25696/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-25696
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-25696
- OSV: https://osv.dev/vulnerability/CVE-2023-25696

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-25696/
Summaries are generated and may contain mistakes; the official description above is the record.
