# CVE-2023-25705: WordPress WP Prayer Plugin <= 1.9.6 is vulnerable to Cross Site Scripting (XSS)

> Administrators can inject malicious scripts into the WP Prayer plugin, potentially leading to session hijacking or site compromise.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 7 Apr 2023
- **Updated:** 28 Apr 2026
- **Also known as:** GHSA-98f9-m98p-r7cv

## What is CVE-2023-25705?

CVE-2023-25705 is a medium-severity cross-site scripting vulnerability in Go Prayer WP Prayer, published on 7 Apr 2023. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

Auth. (admin+) Stored Cross-Site Scripting (XSS) vulnerability in Go Prayer WP Prayer plugin <= 1.9.6 versions.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2023-25705?

It affects 1 product.


Products: Goprayer Wp Prayer.

## How do I fix CVE-2023-25705?

No fix has been published for CVE-2023-25705 yet. Limit exposure of the affected software until one is available.

## Is CVE-2023-25705 being exploited?

There is no known exploitation of CVE-2023-25705 in the wild and no public exploit code.

## Other vulnerabilities in Go Prayer WP Prayer

- [CVE-2024-3406](https://insights.sbomify.com/CVE-2024-3406/): WP Prayer <= 2.0.9 - Email Settings Update via CSRF (high 8.8)
- [CVE-2024-3405](https://insights.sbomify.com/CVE-2024-3405/): WP Prayer <= 2.0.9 - Settings Update via CSRF (high 7.6)
- [CVE-2021-24313](https://insights.sbomify.com/CVE-2021-24313/): WP Prayer < 1.6.2 - Authenticated Stored Cross-Site Scripting (XSS) (medium 5.4)
- [CVE-2024-3407](https://insights.sbomify.com/CVE-2024-3407/): WP Prayer <= 2.0.9 - Arbitrary Prayer Deletion via CSRF (medium 5.3)
- [CVE-2021-4412](https://insights.sbomify.com/CVE-2021-4412/): WP Prayer <= 1.6.5 - Cross-Site Request Forgery Bypass (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-25705 and fix it if it is affected.

What it is: CVE-2023-25705 is a medium-severity cross-site scripting vulnerability in Go Prayer WP Prayer, published on 7 Apr 2023. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-25705 in the wild and no public exploit code.

Affected product: Go Prayer WP Prayer. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-25705/ (Markdown: https://insights.sbomify.com/CVE-2023-25705/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-25705
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-25705
- OSV: https://osv.dev/vulnerability/CVE-2023-25705

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-25705/
Summaries are generated and may contain mistakes; the official description above is the record.
