# CVE-2023-25721: Veracode Scan Jenkins Plugin vulnerable to information disclosure

> Users with job log access can discover proxy credentials when specific debug and proxy settings are enabled in the Veracode Scan Jenkins Plugin.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Mar 2023
- **Updated:** 19 Feb 2025
- **Also known as:** GHSA-c4jr-vjm4-27hq

## What is CVE-2023-25721?

CVE-2023-25721 is a medium-severity vulnerability in n/a, published on 28 Mar 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Veracode Scan Jenkins Plugin before 23.3.19.0, when the "Connect using proxy" option is enabled and configured with proxy credentials and when the Jenkins global system setting debug is enabled and when a scan is configured for remote agent jobs, allows users (with access to view the job log) to discover proxy credentials.

Weakness: CWE-532 (Insertion of Sensitive Information into Log File)

## Which versions are affected by CVE-2023-25721?

2 open source packages ship an affected version, including com.veracode.jenkins:veracode-scan. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.veracode.jenkins:veracode-scan` | Maven | All versions | 23.3.19.0 |
| `com.veracode.jenkins:veracode-scan` | Maven | All versions | 23.3.19.0 |

Products: Veracode Veracode.

## How do I fix CVE-2023-25721?

Upgrade com.veracode.jenkins:veracode-scan to 23.3.19.0 or later.

## Is CVE-2023-25721 being exploited?

There is no known exploitation of CVE-2023-25721 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2023-25722](https://insights.sbomify.com/CVE-2023-25722/): Veracode Scan Jenkins Plugin vulnerable to information disclosure (medium 5.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-25721 and fix it if it is affected.

What it is: CVE-2023-25721 is a medium-severity vulnerability in n/a, published on 28 Mar 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-25721 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.veracode.jenkins:veracode-scan (Maven): affected all versions; fixed in 23.3.19.0
- com.veracode.jenkins:veracode-scan (Maven): affected all versions; fixed in 23.3.19.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-25721/ (Markdown: https://insights.sbomify.com/CVE-2023-25721/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-25721
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-25721
- OSV: https://osv.dev/vulnerability/CVE-2023-25721

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-25721/
Summaries are generated and may contain mistakes; the official description above is the record.
