CVE-2023-25725 Security feature bypass in n/a
Attackers can bypass access controls via HTTP request smuggling by exploiting header parsing flaws in HAProxy, potentially hiding headers from security checks.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2023-25725?
CVE-2023-25725 is a critical vulnerability in Debian Debian Linux, published on 14 Feb 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
HAProxy before 2.7.3 may allow a bypass of access control because HTTP/1 headers are inadvertently lost in some situations, aka "request smuggling." The HTTP header parsers in HAProxy may accept empty header field names, which could be used to truncate the list of HTTP headers and thus make some headers disappear after being parsed and processed for HTTP/1.0 and HTTP/1.1. For HTTP/2 and HTTP/3, the impact is limited because the headers disappear before being parsed and processed, as if they had not been sent by the client. The fixed versions are 2.7.3, 2.6.9, 2.5.12, 2.4.22, 2.2.29, and 2.0.31.
Weakness: CWE-444
Which versions are affected by CVE-2023-25725?
1 open source package ship an affected version, including haproxy. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
haproxy Bitnami | All versions | 2.0.31, 2.2.29, 2.4.22, 2.5.12, 2.6.9, 2.7.3 |
Linux distribution packages (5)
haproxy SUSE:Linux Enterprise High Availability Extension 15 SP4 | All versions | 2.4.8+git0.d1f8d41e0-150400.3.10.1 |
haproxy SUSE:Linux Enterprise Micro 5.3 | All versions | 2.4.8+git0.d1f8d41e0-150400.3.10.1 |
haproxy openSUSE:Leap 15.4 | All versions | 2.4.8+git0.d1f8d41e0-150400.3.10.1 |
haproxy openSUSE:Leap Micro 5.3 | All versions | 2.4.8+git0.d1f8d41e0-150400.3.10.1 |
haproxy openSUSE:Tumbleweed | All versions | 2.7.3+git0.1065b1000-1.1 |
Products include Debian Debian Linux, Haproxy Haproxy.
How do I fix CVE-2023-25725?
Upgrade haproxy to a fixed version for your release line: 2.0.31, 2.2.29, 2.4.22 or 2.5.12.
Is CVE-2023-25725 being exploited?
There is no known exploitation of CVE-2023-25725 in the wild and no public exploit code.
Public exploit code: 1 proofs of concept on GitHub.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as AZL-13569, BIT-haproxy-2023-25725, CLSA-2024-1733908866, DEBIAN-CVE-2023-25725, DLA-3318-1, GHSA-h2p2-w857-329f and 5 more.