# CVE-2023-25725: Security feature bypass in n/a

> Attackers can bypass access controls via HTTP request smuggling by exploiting header parsing flaws in HAProxy, potentially hiding headers from security checks.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Feb 2023
- **Updated:** 20 Mar 2025
- **Also known as:** AZL-13569, BIT-haproxy-2023-25725, CLSA-2024-1733908866, DEBIAN-CVE-2023-25725, DLA-3318-1, GHSA-h2p2-w857-329f, SUSE-SU-2023:0411-1, UBUNTU-CVE-2023-25725, USN-5869-1, USN-7135-1, openSUSE-SU-2024:12686-1

## What is CVE-2023-25725?

CVE-2023-25725 is a critical vulnerability in Debian Debian Linux, published on 14 Feb 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

HAProxy before 2.7.3 may allow a bypass of access control because HTTP/1 headers are inadvertently lost in some situations, aka "request smuggling." The HTTP header parsers in HAProxy may accept empty header field names, which could be used to truncate the list of HTTP headers and thus make some headers disappear after being parsed and processed for HTTP/1.0 and HTTP/1.1. For HTTP/2 and HTTP/3, the impact is limited because the headers disappear before being parsed and processed, as if they had not been sent by the client. The fixed versions are 2.7.3, 2.6.9, 2.5.12, 2.4.22, 2.2.29, and 2.0.31.

Weakness: CWE-444 (Inconsistent Interpretation of HTTP Requests)

## Which versions are affected by CVE-2023-25725?

1 open source package ship an affected version, including haproxy. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `haproxy` | Bitnami | All versions | 2.0.31, 2.2.29, 2.4.22, 2.5.12, 2.6.9, 2.7.3 |
| `haproxy` | SUSE:Linux Enterprise High Availability Extension 15 SP4 | All versions | 2.4.8+git0.d1f8d41e0-150400.3.10.1 |
| `haproxy` | SUSE:Linux Enterprise Micro 5.3 | All versions | 2.4.8+git0.d1f8d41e0-150400.3.10.1 |
| `haproxy` | openSUSE:Leap 15.4 | All versions | 2.4.8+git0.d1f8d41e0-150400.3.10.1 |
| `haproxy` | openSUSE:Leap Micro 5.3 | All versions | 2.4.8+git0.d1f8d41e0-150400.3.10.1 |
| `haproxy` | openSUSE:Tumbleweed | All versions | 2.7.3+git0.1065b1000-1.1 |

Products: Debian Debian Linux, Haproxy Haproxy.

## How do I fix CVE-2023-25725?

Upgrade haproxy to a fixed version for your release line: 2.0.31, 2.2.29, 2.4.22 or 2.5.12.

## Is CVE-2023-25725 being exploited?

There is no known exploitation of CVE-2023-25725 in the wild and no public exploit code.

Public exploit code:

- Lab environment to test CVE-2023-25725 (github_poc): https://github.com/krillingws/LAB-CVE-2023-25725

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-25725 and fix it if it is affected.

What it is: CVE-2023-25725 is a critical vulnerability in Debian Debian Linux, published on 14 Feb 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-25725 in the wild and no public exploit code.

Affected packages and fixed versions:
- haproxy (Bitnami): affected all versions; fixed in 2.0.31, 2.2.29, 2.4.22, 2.5.12, 2.6.9, 2.7.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-25725/ (Markdown: https://insights.sbomify.com/CVE-2023-25725/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-25725
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-25725
- OSV: https://osv.dev/vulnerability/CVE-2023-25725

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-25725/
Summaries are generated and may contain mistakes; the official description above is the record.
