CVE-2023-25727 Cross-site Scripting vulnerability in drag-and-drop upload of phpMyAdmin
Authenticated users can execute arbitrary scripts via crafted SQL file uploads in phpMyAdmin, potentially leading to session hijacking or data theft.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2023-25727?
CVE-2023-25727 is a medium-severity cross-site scripting vulnerability in Phpmyadmin Phpmyadmin, published on 13 Feb 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
In phpMyAdmin before 4.9.11 and 5.x before 5.2.1, an authenticated user can trigger XSS by uploading a crafted .sql file through the drag-and-drop interface.
Weakness: CWE-79
Which versions are affected by CVE-2023-25727?
5 open source packages ship an affected version, including phpmyadmin/phpmyadmin and phpmyadmin. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
phpmyadmin/phpmyadmin Packagist | From 4.3.0 | 4.9.11 |
phpmyadmin/phpmyadmin Packagist | From 4.3.0 | 4.9.11 |
phpmyadmin/phpmyadmin Packagist | From 5.0 | 5.2.1 |
phpmyadmin/phpmyadmin Packagist | From 5.0 | 5.2.1 |
phpmyadmin Bitnami | All versions | 4.9.11, 5.2.1 |
Linux distribution packages (2)
phpMyAdmin SUSE:Package Hub 12 | All versions | 4.9.11-58.1 |
phpMyAdmin openSUSE:Tumbleweed | All versions | 5.2.1-2.1 |
Products include Phpmyadmin Phpmyadmin.
How do I fix CVE-2023-25727?
Upgrade phpmyadmin/phpmyadmin to a fixed version for your release line: 4.9.11 or 5.2.1.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2023-25727 being exploited?
There is no known exploitation of CVE-2023-25727 in the wild and no public exploit code.
Other vulnerabilities in Phpmyadmin Phpmyadmin
Sources
Also known as BIT-phpmyadmin-2023-25727, DEBIAN-CVE-2023-25727, GHSA-6hr3-44gx-g6wh, UBUNTU-CVE-2023-25727, openSUSE-SU-2023:0058-1, openSUSE-SU-2024:12689-1.