# CVE-2023-25727: Cross-site Scripting vulnerability in drag-and-drop upload of phpMyAdmin

> Authenticated users can execute arbitrary scripts via crafted SQL file uploads in phpMyAdmin, potentially leading to session hijacking or data theft.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 13 Feb 2023
- **Updated:** 3 Nov 2025
- **Also known as:** BIT-phpmyadmin-2023-25727, DEBIAN-CVE-2023-25727, GHSA-6hr3-44gx-g6wh, UBUNTU-CVE-2023-25727, openSUSE-SU-2023:0058-1, openSUSE-SU-2024:12689-1

## What is CVE-2023-25727?

CVE-2023-25727 is a medium-severity cross-site scripting vulnerability in Phpmyadmin Phpmyadmin, published on 13 Feb 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

In phpMyAdmin before 4.9.11 and 5.x before 5.2.1, an authenticated user can trigger XSS by uploading a crafted .sql file through the drag-and-drop interface.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2023-25727?

5 open source packages ship an affected version, including phpmyadmin/phpmyadmin and phpmyadmin. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `phpmyadmin/phpmyadmin` | Packagist | From 4.3.0 | 4.9.11 |
| `phpmyadmin/phpmyadmin` | Packagist | From 4.3.0 | 4.9.11 |
| `phpmyadmin/phpmyadmin` | Packagist | From 5.0 | 5.2.1 |
| `phpmyadmin/phpmyadmin` | Packagist | From 5.0 | 5.2.1 |
| `phpmyadmin` | Bitnami | All versions | 4.9.11, 5.2.1 |
| `phpMyAdmin` | SUSE:Package Hub 12 | All versions | 4.9.11-58.1 |
| `phpMyAdmin` | openSUSE:Tumbleweed | All versions | 5.2.1-2.1 |

Products: Phpmyadmin Phpmyadmin.

## How do I fix CVE-2023-25727?

Upgrade phpmyadmin/phpmyadmin to a fixed version for your release line: 4.9.11 or 5.2.1.

## Is CVE-2023-25727 being exploited?

There is no known exploitation of CVE-2023-25727 in the wild and no public exploit code.

## Other vulnerabilities in Phpmyadmin Phpmyadmin

- [CVE-2008-7251](https://insights.sbomify.com/CVE-2008-7251/): Misconfiguration in n/a (critical 10.0)
- [CVE-2008-7252](https://insights.sbomify.com/CVE-2008-7252/): phpMyAdmin unsafely handles temporary files (critical 10.0)
- [CVE-2007-0203](https://insights.sbomify.com/CVE-2007-0203/): Other in n/a (critical 10.0)
- [CVE-2004-1147](https://insights.sbomify.com/CVE-2004-1147/): Command injection in n/a (critical 10.0)
- [CVE-2020-22452](https://insights.sbomify.com/CVE-2020-22452/): phpmyadmin contains SQL Injection vulnerability (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-25727 and fix it if it is affected.

What it is: CVE-2023-25727 is a medium-severity cross-site scripting vulnerability in Phpmyadmin Phpmyadmin, published on 13 Feb 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-25727 in the wild and no public exploit code.

Affected packages and fixed versions:
- phpmyadmin/phpmyadmin (Packagist): affected from 4.3.0; fixed in 4.9.11
- phpmyadmin/phpmyadmin (Packagist): affected from 4.3.0; fixed in 4.9.11
- phpmyadmin/phpmyadmin (Packagist): affected from 5.0; fixed in 5.2.1
- phpmyadmin/phpmyadmin (Packagist): affected from 5.0; fixed in 5.2.1
- phpmyadmin (Bitnami): affected all versions; fixed in 4.9.11, 5.2.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-25727/ (Markdown: https://insights.sbomify.com/CVE-2023-25727/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-25727
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-25727
- OSV: https://osv.dev/vulnerability/CVE-2023-25727

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-25727/
Summaries are generated and may contain mistakes; the official description above is the record.
