# CVE-2023-25753: Server-Side Request Forgery in Apache ShenYu

> Attackers can exploit an SSRF vulnerability in Apache ShenYu to send arbitrary HTTP requests to internal or external hosts, potentially accessing sensitive data.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Oct 2023
- **Updated:** 12 Sep 2024
- **Also known as:** GHSA-7w8v-5fcq-pvqw

## What is CVE-2023-25753?

CVE-2023-25753 is a medium-severity server-side request forgery vulnerability in Apache ShenYu, published on 19 Oct 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

There exists an SSRF (Server-Side Request Forgery) vulnerability located at the /sandbox/proxyGateway endpoint. This vulnerability allows us to manipulate arbitrary requests and retrieve corresponding responses by inputting any URL into the requestUrl parameter.

Of particular concern is our ability to exert control over the HTTP method, cookies, IP address, and headers. This effectively grants us the capability to dispatch complete HTTP requests to hosts of our choosing.

This issue affects Apache ShenYu: 2.5.1.

Upgrade to Apache ShenYu 2.6.0 or apply patch  https://github.com/apache/shenyu/pull/4776  .

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2023-25753?

4 open source packages ship an affected version, including org.apache.shenyu:shenyu-admin and org.apache.shenyu:shenyu-common. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.shenyu:shenyu-admin` | Maven | All versions | 2.6.0 |
| `org.apache.shenyu:shenyu-admin` | Maven | All versions | 2.6.0 |
| `org.apache.shenyu:shenyu-common` | Maven | All versions | 2.6.0 |
| `org.apache.shenyu:shenyu-common` | Maven | All versions | 2.6.0 |

Products: Apache Shenyu.

## How do I fix CVE-2023-25753?

Upgrade org.apache.shenyu:shenyu-admin to 2.6.0 or later.

## Is CVE-2023-25753 being exploited?

There is no known exploitation of CVE-2023-25753 in the wild and no public exploit code.

## Other vulnerabilities in Apache ShenYu

- [CVE-2021-45029](https://insights.sbomify.com/CVE-2021-45029/): Apache ShenYu 2.4.1 Groovy Code Injection & SpEL Injection (critical 9.8)
- [CVE-2021-37580](https://insights.sbomify.com/CVE-2021-37580/): Apache ShenYu Admin bypass JWT authentication (critical 9.8)
- [CVE-2022-23944](https://insights.sbomify.com/CVE-2022-23944/): Apache ShenYu 2.4.1 Improper access control (critical 9.1)
- [CVE-2022-42735](https://insights.sbomify.com/CVE-2022-42735/): Apache ShenYu Admin ultra vires (high 8.8)
- [CVE-2022-37435](https://insights.sbomify.com/CVE-2022-37435/): Apache ShenYu Admin Improper Privilege Management (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-25753 and fix it if it is affected.

What it is: CVE-2023-25753 is a medium-severity server-side request forgery vulnerability in Apache ShenYu, published on 19 Oct 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-25753 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.shenyu:shenyu-admin (Maven): affected all versions; fixed in 2.6.0
- org.apache.shenyu:shenyu-admin (Maven): affected all versions; fixed in 2.6.0
- org.apache.shenyu:shenyu-common (Maven): affected all versions; fixed in 2.6.0
- org.apache.shenyu:shenyu-common (Maven): affected all versions; fixed in 2.6.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-25753/ (Markdown: https://insights.sbomify.com/CVE-2023-25753/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-25753
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-25753
- OSV: https://osv.dev/vulnerability/CVE-2023-25753

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-25753/
Summaries are generated and may contain mistakes; the official description above is the record.
