# CVE-2023-25754: Apache Airflow: Privilege escalation using airflow logs

> Attackers can escalate privileges by exploiting a context switching error in Apache Airflow logs, requiring an upgrade to secure the system.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 May 2023
- **Updated:** 13 Feb 2025
- **Also known as:** BIT-airflow-2023-25754, GHSA-jchm-fm4q-c2fp, PYSEC-2023-59

## What is CVE-2023-25754?

CVE-2023-25754 is a critical vulnerability in Apache Airflow, published on 8 May 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Privilege Context Switching Error vulnerability in Apache Software Foundation Apache Airflow.This issue affects Apache Airflow: before 2.6.0.

Weakness: CWE-270 (Privilege Context Switching Error)

## Which versions are affected by CVE-2023-25754?

4 open source packages ship an affected version, including apache-airflow and airflow. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache-airflow` | PyPI | All versions | 2.6.0 |
| `apache-airflow` | PyPI | All versions | 2.6.0b1 |
| `apache-airflow` | PyPI | All versions | 2.6.0b1 |
| `airflow` | Bitnami | All versions | 2.6.0 |

Products: Apache Airflow.

## How do I fix CVE-2023-25754?

Upgrade apache-airflow to a fixed version for your release line: 2.6.0 or 2.6.0b1.

## Is CVE-2023-25754 being exploited?

There is no known exploitation of CVE-2023-25754 in the wild and no public exploit code.

## Other vulnerabilities in Apache Airflow

- [CVE-2020-13927](https://insights.sbomify.com/CVE-2020-13927/): Apache Airflow's Experimental API Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2020-11978](https://insights.sbomify.com/CVE-2020-11978/): Apache Airflow Command Injection (high 8.8, exploited in the wild)
- [CVE-2026-33264](https://insights.sbomify.com/CVE-2026-33264/): Apache Airflow: DAG author RCE on webserver via unrestricted import_string() in BaseSerialization.deserialize() (critical 9.8)
- [CVE-2023-22884](https://insights.sbomify.com/CVE-2023-22884/): Apache Airflow, Apache Airflow MySQL Provider: Arbitrary file read via MySQL provider in Apache Airflow (critical 9.8)
- [CVE-2022-38649](https://insights.sbomify.com/CVE-2022-38649/): Apache Airflow Pinot provider allowed Command Injection (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-25754 and fix it if it is affected.

What it is: CVE-2023-25754 is a critical vulnerability in Apache Airflow, published on 8 May 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-25754 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache-airflow (PyPI): affected all versions; fixed in 2.6.0
- apache-airflow (PyPI): affected all versions; fixed in 2.6.0b1
- apache-airflow (PyPI): affected all versions; fixed in 2.6.0b1
- airflow (Bitnami): affected all versions; fixed in 2.6.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-25754/ (Markdown: https://insights.sbomify.com/CVE-2023-25754/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-25754
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-25754
- OSV: https://osv.dev/vulnerability/CVE-2023-25754

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-25754/
Summaries are generated and may contain mistakes; the official description above is the record.
