{"answers":{"affected":"2 open source packages ship an affected version, including org.jenkins-ci.plugins:email-ext. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-25763 in the wild and no public exploit code.","fix":"Upgrade org.jenkins-ci.plugins:email-ext to 2.94 or later.","what":"CVE-2023-25763 is a medium-severity cross-site scripting vulnerability in Jenkins Email Extension Plugin, published on 15 Feb 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2023-25763 and fix it if it is affected.\n\nWhat it is: CVE-2023-25763 is a medium-severity cross-site scripting vulnerability in Jenkins Email Extension Plugin, published on 15 Feb 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2023-25763 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.jenkins-ci.plugins:email-ext (Maven): affected all versions; fixed in 2.94\n- org.jenkins-ci.plugins:email-ext (Maven): affected all versions; fixed in 2.94\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-25763/ (Markdown: https://insights.sbomify.com/CVE-2023-25763/index.md)","id":"CVE-2023-25763","markdown":"https://insights.sbomify.com/CVE-2023-25763/index.md","name":"CVE-2023-25763","record":{"aliases":["GHSA-h97r-fchm-m23x"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins Email Extension Plugin","requires_auth":"low_privilege","summary":"Stored XSS in Jenkins Email Extension Plugin allows attackers to inject scripts via email templates, potentially leading to session hijacking or code execution.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"jenkins","cpe":[{"product":"email_extension","vendor":"jenkins"}],"cvss":{"score":5.4,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Jenkins Email Extension Plugin 2.93 and earlier does not escape various fields included in bundled email templates, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers able to control affected fields.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Cross-site Scripting in Jenkins Email Extension Plugin","id":"CVE-2023-25763","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"xss","year":"2023"},"n_packages":2,"n_references":2,"next":{"headline":"Cross-site Scripting in Jenkins Email Extension Plugin","id":"CVE-2023-25764"},"packages":[{"ecosystem":"Maven","fixed":["2.94"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:email-ext","purl":null,"source":"GHSA-h97r-fchm-m23x"},{"ecosystem":"Maven","fixed":["2.94"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:email-ext","purl":"pkg:maven/org.jenkins-ci.plugins/email-ext","source":"GHSA-h97r-fchm-m23x"}],"prev":{"headline":"Cross-site Scripting in Jenkins Pipeline: Build Step Plugin","id":"CVE-2023-25762"},"products":["Jenkins Email Extension Plugin"],"published":"2023-02-15","related":[{"cvss_score":9.9,"headline":"Sandbox escape in Jenkins Email Extension Plugin","id":"CVE-2023-25765","kev_date_added":null,"published":"2023-02-15"},{"cvss_score":9.9,"headline":"Script security sandbox bypass in Jenkins Email Extension Plugin","id":"CVE-2019-1003032","kev_date_added":null,"published":"2019-03-08"},{"cvss_score":8.8,"headline":"Jenkins Email Extension Plugin: Attackers able to control email content may specify `file:` URLs for images to read arbitrary files from Jenkins controller filesystem","id":"CVE-2026-48920","kev_date_added":null,"published":"2026-05-27"},{"cvss_score":7.5,"headline":"Jenkins Email Extension Plugin SMTP password transmitted and displayed in plain text","id":"CVE-2020-2232","kev_date_added":null,"published":"2020-08-12"},{"cvss_score":6.5,"headline":"Jenkins Email Extension Plugin showed plain text SMTP password in configuration form field","id":"CVE-2018-1000176","kev_date_added":null,"published":"2018-05-08"},{"cvss_score":5.4,"headline":"Cross-site Scripting in Jenkins Email Extension Plugin","id":"CVE-2023-25764","kev_date_added":null,"published":"2023-02-15"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-03-19","vendors":["Jenkins Project"]},"summary":"Stored XSS in Jenkins Email Extension Plugin allows attackers to inject scripts via email templates, potentially leading to session hijacking or code execution.","url":"https://insights.sbomify.com/CVE-2023-25763/"}