CVE-2023-25801 TensorFlow has double free in Fractional(Max/Avg)Pool
An attacker can trigger a double free in TensorFlow's fractional pooling operations, potentially leading to code execution or denial of service.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Local or same network only
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2023-25801?
CVE-2023-25801 is a high-severity use after free vulnerability in Google Tensorflow, published on 24 Mar 2023. It can only be exploited from the same machine or local network, with no action from the victim.
Official description
TensorFlow is an open source machine learning platform. Prior to versions 2.12.0 and 2.11.1, `nn_ops.fractional_avg_pool_v2` and `nn_ops.fractional_max_pool_v2` require the first and fourth elements of their parameter `pooling_ratio` to be equal to 1.0, as pooling on batch and channel dimensions is not supported. A fix is included in TensorFlow 2.12.0 and 2.11.1.
Weakness: CWE-415
Which versions are affected by CVE-2023-25801?
10 open source packages ship an affected version, including tensorflow, tensorflow-cpu and tensorflow-gpu. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
tensorflow Bitnami | All versions | 2.12.0 |
tensorflow PyPI | All versions | 2.11.1 |
tensorflow PyPI | All versions | 2.11.1 |
tensorflow PyPI | All versions | 2.11.1 |
tensorflow-cpu PyPI | All versions | 2.11.1 |
tensorflow-cpu PyPI | All versions | 2.11.1 |
4 more packages
tensorflow-cpu PyPI | All versions | 2.11.1 |
tensorflow-gpu PyPI | All versions | 2.11.1 |
tensorflow-gpu PyPI | All versions | 2.11.1 |
tensorflow-gpu PyPI | All versions | 2.11.1 |
Products include Google Tensorflow.
How do I fix CVE-2023-25801?
Upgrade tensorflow to a fixed version for your release line: 2.12.0 or 2.11.1.
Upgrade to the fixed version. These bugs are found with fuzzing and sanitisers and avoided by memory-safe languages. More about Use after free.
Is CVE-2023-25801 being exploited?
There is no known exploitation of CVE-2023-25801 in the wild and no public exploit code.
Other vulnerabilities in Google Tensorflow
- CVE-2023-25668 TensorFlow vulnerable to heap out-of-buffer read in the QuantizeAndDequantize operation
- CVE-2018-7575 Integer Overflow or Wraparound in Google TensorFlow
- CVE-2021-37678 Arbitrary code execution due to YAML deserialization
- CVE-2021-35958 Path traversal in n/a
- CVE-2020-15202 Integer truncation in Shard API usage
Sources
Also known as AZL-31206, AZL-35322, BIT-tensorflow-2023-25801, GHSA-f49c-87jh-g47q, PYSEC-2026-3166, PYSEC-2026-3314 and 1 more.