# CVE-2023-25801: TensorFlow has double free in Fractional(Max/Avg)Pool

> An attacker can trigger a double free in TensorFlow's fractional pooling operations, potentially leading to code execution or denial of service.

- **Severity:** High 8.0 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Mar 2023
- **Updated:** 19 Feb 2025
- **Also known as:** AZL-31206, AZL-35322, BIT-tensorflow-2023-25801, GHSA-f49c-87jh-g47q, PYSEC-2026-3166, PYSEC-2026-3314, PYSEC-2026-985

## What is CVE-2023-25801?

CVE-2023-25801 is a high-severity use after free vulnerability in Google Tensorflow, published on 24 Mar 2023. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

TensorFlow is an open source machine learning platform. Prior to versions 2.12.0 and 2.11.1, `nn_ops.fractional_avg_pool_v2` and `nn_ops.fractional_max_pool_v2` require the first and fourth elements of their parameter `pooling_ratio` to be equal to 1.0, as pooling on batch and channel dimensions is not supported. A fix is included in TensorFlow 2.12.0 and 2.11.1.

Weakness: CWE-415 (Double Free)

## Which versions are affected by CVE-2023-25801?

10 open source packages ship an affected version, including tensorflow, tensorflow-cpu and tensorflow-gpu. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `tensorflow` | Bitnami | All versions | 2.12.0 |
| `tensorflow` | PyPI | All versions | 2.11.1 |
| `tensorflow` | PyPI | All versions | 2.11.1 |
| `tensorflow` | PyPI | All versions | 2.11.1 |
| `tensorflow-cpu` | PyPI | All versions | 2.11.1 |
| `tensorflow-cpu` | PyPI | All versions | 2.11.1 |
| `tensorflow-cpu` | PyPI | All versions | 2.11.1 |
| `tensorflow-gpu` | PyPI | All versions | 2.11.1 |
| `tensorflow-gpu` | PyPI | All versions | 2.11.1 |
| `tensorflow-gpu` | PyPI | All versions | 2.11.1 |

Products: Google Tensorflow.

## How do I fix CVE-2023-25801?

Upgrade tensorflow to a fixed version for your release line: 2.12.0 or 2.11.1.

## Is CVE-2023-25801 being exploited?

There is no known exploitation of CVE-2023-25801 in the wild and no public exploit code.

## Other vulnerabilities in Google Tensorflow

- [CVE-2023-25668](https://insights.sbomify.com/CVE-2023-25668/): TensorFlow vulnerable to heap out-of-buffer read in the QuantizeAndDequantize operation (critical 9.8)
- [CVE-2018-7575](https://insights.sbomify.com/CVE-2018-7575/): Integer Overflow or Wraparound in Google TensorFlow (critical 9.8)
- [CVE-2021-37678](https://insights.sbomify.com/CVE-2021-37678/): Arbitrary code execution due to YAML deserialization (critical 9.3)
- [CVE-2021-35958](https://insights.sbomify.com/CVE-2021-35958/): Path traversal in n/a (critical 9.1)
- [CVE-2020-15202](https://insights.sbomify.com/CVE-2020-15202/): Integer truncation in Shard API usage (critical 9.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-25801 and fix it if it is affected.

What it is: CVE-2023-25801 is a high-severity use after free vulnerability in Google Tensorflow, published on 24 Mar 2023. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-25801 in the wild and no public exploit code.

Affected packages and fixed versions:
- tensorflow (Bitnami): affected all versions; fixed in 2.12.0
- tensorflow (PyPI): affected all versions; fixed in 2.11.1
- tensorflow (PyPI): affected all versions; fixed in 2.11.1
- tensorflow (PyPI): affected all versions; fixed in 2.11.1
- tensorflow-cpu (PyPI): affected all versions; fixed in 2.11.1
- tensorflow-cpu (PyPI): affected all versions; fixed in 2.11.1
- tensorflow-cpu (PyPI): affected all versions; fixed in 2.11.1
- tensorflow-gpu (PyPI): affected all versions; fixed in 2.11.1
- tensorflow-gpu (PyPI): affected all versions; fixed in 2.11.1
- tensorflow-gpu (PyPI): affected all versions; fixed in 2.11.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-25801/ (Markdown: https://insights.sbomify.com/CVE-2023-25801/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-25801
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-25801
- OSV: https://osv.dev/vulnerability/CVE-2023-25801

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-25801/
Summaries are generated and may contain mistakes; the official description above is the record.
