# CVE-2023-25803: Path traversal in roxy-wi

> Attackers can read arbitrary server-side files via directory traversal in Roxy-WI, exposing sensitive configuration data.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 13 Mar 2023
- **Updated:** 25 Feb 2025
- **Also known as:** GHSA-cv9w-j9gh-5j3w

## What is CVE-2023-25803?

CVE-2023-25803 is a high-severity path traversal vulnerability in hap-wi roxy-wi, published on 13 Mar 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Roxy-WI is a Web interface for managing Haproxy, Nginx, Apache, and Keepalived servers. Versions prior to 6.3.5.0 have a directory traversal vulnerability that allows the inclusion of server-side files. This issue is fixed in version 6.3.5.0.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2023-25803?

It affects 1 product.


Products: Roxy-Wi Roxy-Wi.

## How do I fix CVE-2023-25803?

No fix has been published for CVE-2023-25803 yet. Limit exposure of the affected software until one is available.

## Is CVE-2023-25803 being exploited?

There is no known exploitation of CVE-2023-25803 in the wild and no public exploit code.

## Other vulnerabilities in hap-wi roxy-wi

- [CVE-2022-31161](https://insights.sbomify.com/CVE-2022-31161/): Roxy-WI Vulnerable to Unauthenticated Remote Code Execution via ssl_cert Upload (critical 10.0)
- [CVE-2022-31137](https://insights.sbomify.com/CVE-2022-31137/): Unauthenticated Remote Code Execution in Roxy-WI (critical 10.0)
- [CVE-2022-31125](https://insights.sbomify.com/CVE-2022-31125/): Authentication Bypass in Roxy-wi (critical 10.0)
- [CVE-2022-31126](https://insights.sbomify.com/CVE-2022-31126/): Unauthenticated Remote Code Execution in Roxy-wi (critical 10.0)
- [CVE-2021-38167](https://insights.sbomify.com/CVE-2021-38167/): SQL injection in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-25803 and fix it if it is affected.

What it is: CVE-2023-25803 is a high-severity path traversal vulnerability in hap-wi roxy-wi, published on 13 Mar 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-25803 in the wild and no public exploit code.

Affected product: hap-wi roxy-wi. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-25803/ (Markdown: https://insights.sbomify.com/CVE-2023-25803/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-25803
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-25803
- OSV: https://osv.dev/vulnerability/CVE-2023-25803

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-25803/
Summaries are generated and may contain mistakes; the official description above is the record.
