{"answers":{"affected":"2 open source packages ship an affected version, including versionn. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-25805 in the wild and no public exploit code.","fix":"Upgrade versionn to 1.1.0 or later.","what":"CVE-2023-25805 is a critical vulnerability in commenthol versionn, published on 20 Feb 2023."},"fix_prompt":"Check this codebase for CVE-2023-25805 and fix it if it is affected.\n\nWhat it is: CVE-2023-25805 is a critical vulnerability in commenthol versionn, published on 20 Feb 2023. \nExploitation: There is no known exploitation of CVE-2023-25805 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- versionn (npm): affected all versions; fixed in 1.1.0\n- versionn (npm): affected all versions; fixed in 1.1.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-25805/ (Markdown: https://insights.sbomify.com/CVE-2023-25805/index.md)","id":"CVE-2023-25805","markdown":"https://insights.sbomify.com/CVE-2023-25805/index.md","name":"CVE-2023-25805","record":{"aliases":["GHSA-fj78-2vc5-f6cm"],"analysis":null,"analysis_generated_by":null,"assigner":"GitHub_M","cpe":[{"product":"versionn","vendor":"versionn_project"}],"cvss":{"score":9.8,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-77","name":"Improper Neutralization of Special Elements used in a Command"}],"description":"versionn, software for changing version information across multiple files, has a command injection vulnerability in all versions prior to version 1.1.0. This issue is patched in version 1.1.0.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"versionn Command Injection Vulnerability","id":"CVE-2023-25805","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":null,"year":"2023"},"n_packages":2,"n_references":2,"next":{"headline":"Time discrepancy in authentication responses in OpenSearch","id":"CVE-2023-25806"},"packages":[{"ecosystem":"npm","fixed":["1.1.0"],"introduced":["0"],"last_affected":[],"package":"versionn","purl":null,"source":"GHSA-fj78-2vc5-f6cm"},{"ecosystem":"npm","fixed":["1.1.0"],"introduced":["0"],"last_affected":[],"package":"versionn","purl":"pkg:npm/versionn","source":"GHSA-fj78-2vc5-f6cm"}],"prev":{"headline":"Roxy-WI vulnerable to Limited Path Traversal in name parameter","id":"CVE-2023-25804"},"products":["versionn"],"published":"2023-02-20","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-03-10","vendors":["commenthol"]},"summary":null,"url":"https://insights.sbomify.com/CVE-2023-25805/"}