# CVE-2023-25805: versionn Command Injection Vulnerability


- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 20 Feb 2023
- **Updated:** 10 Mar 2025
- **Also known as:** GHSA-fj78-2vc5-f6cm

## What is CVE-2023-25805?

CVE-2023-25805 is a critical vulnerability in commenthol versionn, published on 20 Feb 2023. 

### Official description

versionn, software for changing version information across multiple files, has a command injection vulnerability in all versions prior to version 1.1.0. This issue is patched in version 1.1.0.

Weakness: CWE-77 (Improper Neutralization of Special Elements used in a Command)

## Which versions are affected by CVE-2023-25805?

2 open source packages ship an affected version, including versionn. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `versionn` | npm | All versions | 1.1.0 |
| `versionn` | npm | All versions | 1.1.0 |

Products: Versionn Project Versionn.

## How do I fix CVE-2023-25805?

Upgrade versionn to 1.1.0 or later.

## Is CVE-2023-25805 being exploited?

There is no known exploitation of CVE-2023-25805 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-25805 and fix it if it is affected.

What it is: CVE-2023-25805 is a critical vulnerability in commenthol versionn, published on 20 Feb 2023. 
Exploitation: There is no known exploitation of CVE-2023-25805 in the wild and no public exploit code.

Affected packages and fixed versions:
- versionn (npm): affected all versions; fixed in 1.1.0
- versionn (npm): affected all versions; fixed in 1.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-25805/ (Markdown: https://insights.sbomify.com/CVE-2023-25805/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-25805
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-25805
- OSV: https://osv.dev/vulnerability/CVE-2023-25805

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-25805/
Summaries are generated and may contain mistakes; the official description above is the record.
