# CVE-2023-25809: rootless: `/sys/fs/cgroup` is writable when cgroupns isn't unshared in runc

> Rootless runc allows containers to write to host cgroup hierarchies when cgroup namespaces are not unshared, enabling privilege escalation.

- **Severity:** Medium 5.0 (`CVSS:3.1/AV:L/AC:H/PR:H/UI:N/S:C/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Mar 2023
- **Updated:** 12 Feb 2025
- **Also known as:** AZL-25851, CLEANSTART-2026-OE93355, DEBIAN-CVE-2023-25809, GHSA-m8cg-xc2p-r3fc, GO-2023-1682, UBUNTU-CVE-2023-25809

## What is CVE-2023-25809?

CVE-2023-25809 is a medium-severity vulnerability in opencontainers runc, published on 29 Mar 2023. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

runc is a CLI tool for spawning and running containers according to the OCI specification. In affected versions it was found that rootless runc makes `/sys/fs/cgroup` writable in following conditons: 1. when runc is executed inside the user namespace, and the `config.json` does not specify the cgroup namespace to be unshared (e.g.., `(docker|podman|nerdctl) run --cgroupns=host`, with Rootless Docker/Podman/nerdctl) or 2. when runc is executed outside the user namespace, and `/sys` is mounted with `rbind, ro` (e.g., `runc spec --rootless`; this condition is very rare). A container may gain the write access to user-owned cgroup hierarchy `/sys/fs/cgroup/user.slice/...` on the host . Other users's cgroup hierarchies are not affected. Users are advised to upgrade to version 1.1.5. Users unable to upgrade may unshare the cgroup namespace (`(docker|podman|nerdctl) run --cgroupns=private)`. This is the default behavior of Docker/Podman/nerdctl on cgroup v2 hosts. or add `/sys/fs/cgroup` to `maskedPaths`.

Weakness: CWE-281 (Improper Preservation of Permissions)

## Which versions are affected by CVE-2023-25809?

3 open source packages ship an affected version, including github.com/opencontainers/runc. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/opencontainers/runc` | Go | All versions | 1.1.5 |
| `github.com/opencontainers/runc` | Go | All versions | 1.1.5 |
| `github.com/opencontainers/runc` | Go | All versions | 1.1.5 |

Products: Linuxfoundation Runc.

## How do I fix CVE-2023-25809?

Upgrade github.com/opencontainers/runc to 1.1.5 or later.

## Is CVE-2023-25809 being exploited?

There is no known exploitation of CVE-2023-25809 in the wild and no public exploit code.

## Other vulnerabilities in opencontainers runc

- [CVE-2025-52565](https://insights.sbomify.com/CVE-2025-52565/): container escape due to /dev/console mount and related races (high 8.4)
- [CVE-2025-31133](https://insights.sbomify.com/CVE-2025-31133/): runc container escape via "masked path" abuse due to mount race conditions (high 7.3)
- [CVE-2025-52881](https://insights.sbomify.com/CVE-2025-52881/): runc: LSM labels can be bypassed with malicious config using dummy procfs files (high 7.3)
- [CVE-2023-28642](https://insights.sbomify.com/CVE-2023-28642/): AppArmor bypass with symlinked /proc in runc (medium 6.1)
- [CVE-2024-45310](https://insights.sbomify.com/CVE-2024-45310/): runc can be confused to create empty files/directories on the host (low 3.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-25809 and fix it if it is affected.

What it is: CVE-2023-25809 is a medium-severity vulnerability in opencontainers runc, published on 29 Mar 2023. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-25809 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/opencontainers/runc (Go): affected all versions; fixed in 1.1.5
- github.com/opencontainers/runc (Go): affected all versions; fixed in 1.1.5
- github.com/opencontainers/runc (Go): affected all versions; fixed in 1.1.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-25809/ (Markdown: https://insights.sbomify.com/CVE-2023-25809/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-25809
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-25809
- OSV: https://osv.dev/vulnerability/CVE-2023-25809

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-25809/
Summaries are generated and may contain mistakes; the official description above is the record.
