CVE-2023-25822 ReportPortal DoS vulnerability on creating a Launch with too many recursively nested elements

Medium 6.3 Published Updated

Attackers can cause denial of service in ReportPortal by creating launches with excessively nested elements, requiring an upgrade to fix.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2023-25822?

CVE-2023-25822 is a medium-severity denial of service vulnerability in reportportal, published on 9 Oct 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

ReportPortal is an AI-powered test automation platform. Prior to version 5.10.0 of the `com.epam.reportportal:service-api` module, corresponding to ReportPortal version 23.2, the ReportPortal database becomes unstable and reporting almost fully stops except for small launches with approximately 1 test inside when the test_item.path field is exceeded the allowable `ltree` field type indexing limit (path length>=120, approximately recursive nesting of the nested steps). REINDEX INDEX path_gist_idx and path_idx aren't helped. The problem was fixed in `com.epam.reportportal:service-api` module version 5.10.0 (product release 23.2), where the maximum number of nested elements were programmatically limited. A workaround is available. After deletion of the data with long paths, and reindexing both indexes (path_gist_idx and path_idx), the database becomes stable and ReportPortal works properly.

Weakness: CWE-770

Which versions are affected by CVE-2023-25822?

2 open source packages ship an affected version, including com.epam.reportportal:service-api. It affects 2 products.

PackageAffectedFixed in
com.epam.reportportal:service-api MavenAll versions5.10.0
com.epam.reportportal:service-api MavenAll versions5.10.0

Products include Reportportal Reportportal, Reportportal Service-Api.

How do I fix CVE-2023-25822?

Upgrade com.epam.reportportal:service-api to 5.10.0 or later.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2023-25822 being exploited?

There is no known exploitation of CVE-2023-25822 in the wild and no public exploit code.

Sources

Also known as GHSA-mj24-gpw7-23m9.

Is CVE-2023-25822 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free