# CVE-2023-2585: Keycloak: client access via device auth request spoof

> Attackers can spoof device authorization requests to trick admins into granting consent to malicious OAuth clients, leading to unauthorized access.

- **Severity:** Low 3.5 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 21 Dec 2023
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-f5h4-wmp5-xhg6

## What is CVE-2023-2585?

CVE-2023-2585 is a low-severity authentication bypass vulnerability in Redhat Openshift Container Platform, published on 21 Dec 2023. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

Keycloak's device authorization grant does not correctly validate the device code and client ID. An attacker client could abuse the missing validation to spoof a client consent request and trick an authorization admin into granting consent to a malicious OAuth client or possible unauthorized access to an existing OAuth client.

Weakness: CWE-358 (Improperly Implemented Security Check for Standard)

## Which versions are affected by CVE-2023-2585?

4 open source packages ship an affected version, including org.keycloak:keycloak-server-spi-private and org.keycloak:keycloak-services. It affects 5 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.keycloak:keycloak-server-spi-private` | Maven | All versions | 21.1.2 |
| `org.keycloak:keycloak-server-spi-private` | Maven | All versions | 21.1.2 |
| `org.keycloak:keycloak-services` | Maven | All versions | 21.1.2 |
| `org.keycloak:keycloak-services` | Maven | All versions | 21.1.2 |

Products: Redhat Openshift Container Platform, Redhat Openshift Container Platform for Ibm Z, Redhat Openshift Container Platform for Linuxone, Redhat Openshift Container Platform for Power, Redhat Single Sign-On.

## How do I fix CVE-2023-2585?

Upgrade org.keycloak:keycloak-server-spi-private to 21.1.2 or later.

## Is CVE-2023-2585 being exploited?

There is no known exploitation of CVE-2023-2585 in the wild and no public exploit code.

## Other vulnerabilities in Redhat Openshift Container Platform

- [CVE-2020-27836](https://insights.sbomify.com/CVE-2020-27836/): Missing authorization in cluster-ingress-operator (critical 9.8)
- [CVE-2018-1085](https://insights.sbomify.com/CVE-2018-1085/): Misconfiguration in openshift-ansible (critical 9.0)
- [CVE-2026-54099](https://insights.sbomify.com/CVE-2026-54099/): Privilege escalation in Red Hat OpenShift Container Platform 4 (high 8.8)
- [CVE-2026-1784](https://insights.sbomify.com/CVE-2026-1784/): Ose-cluster-ingress-operator: remote code execution through haproxy configuration injection (high 8.8)
- [CVE-2021-20182](https://insights.sbomify.com/CVE-2021-20182/): Privilege escalation in openshift (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-2585 and fix it if it is affected.

What it is: CVE-2023-2585 is a low-severity authentication bypass vulnerability in Redhat Openshift Container Platform, published on 21 Dec 2023. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-2585 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.keycloak:keycloak-server-spi-private (Maven): affected all versions; fixed in 21.1.2
- org.keycloak:keycloak-server-spi-private (Maven): affected all versions; fixed in 21.1.2
- org.keycloak:keycloak-services (Maven): affected all versions; fixed in 21.1.2
- org.keycloak:keycloak-services (Maven): affected all versions; fixed in 21.1.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-2585/ (Markdown: https://insights.sbomify.com/CVE-2023-2585/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-2585
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-2585
- OSV: https://osv.dev/vulnerability/CVE-2023-2585

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-2585/
Summaries are generated and may contain mistakes; the official description above is the record.
