# CVE-2023-25956: Apache Airflow AWS Provider: Arbitrary file read via AWS provider

> Attackers can read arbitrary files via sensitive information in error messages in the Apache Airflow AWS Provider.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Feb 2023
- **Updated:** 23 Oct 2024
- **Also known as:** GHSA-w695-p3j5-hrj9, PYSEC-2026-771, ROOT-APP-PYPI-CVE-2023-25956

## What is CVE-2023-25956?

CVE-2023-25956 is a high-severity vulnerability in Apache Airflow AWS Provider, published on 24 Feb 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Generation of Error Message Containing Sensitive Information vulnerability in the Apache Airflow AWS Provider.

This issue affects Apache Airflow AWS Provider versions before 7.2.1.

Weakness: CWE-209 (Generation of Error Message Containing Sensitive Information)

## Which versions are affected by CVE-2023-25956?

3 open source packages ship an affected version, including apache-airflow-providers-amazon. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache-airflow-providers-amazon` | PyPI | All versions | 7.2.1 |
| `apache-airflow-providers-amazon` | PyPI | All versions | 7.2.1 |
| `apache-airflow-providers-amazon` | PyPI | All versions | 7.2.1 |

Products: Apache Apache-Airflow-Providers-Amazon.

## How do I fix CVE-2023-25956?

Upgrade apache-airflow-providers-amazon to 7.2.1 or later.

## Is CVE-2023-25956 being exploited?

There is no known exploitation of CVE-2023-25956 in the wild and no public exploit code.

## Other vulnerabilities in Apache Airflow AWS Provider

- [CVE-2026-68872](https://insights.sbomify.com/CVE-2026-68872/): Missing authorization in Apache Airflow Amazon provider (medium 6.5)
- [CVE-2026-25604](https://insights.sbomify.com/CVE-2026-25604/): Apache Airflow AWS Auth Manager - Host Header Injection Leading to SAML Authentication Bypass (medium 5.4)
- [CVE-2026-42526](https://insights.sbomify.com/CVE-2026-42526/): Apache Airflow Amazon provider: Prevent unauthorized access to team-scoped secrets in AWS Secrets Manager and SSM Parameter Store backends (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-25956 and fix it if it is affected.

What it is: CVE-2023-25956 is a high-severity vulnerability in Apache Airflow AWS Provider, published on 24 Feb 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-25956 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache-airflow-providers-amazon (PyPI): affected all versions; fixed in 7.2.1
- apache-airflow-providers-amazon (PyPI): affected all versions; fixed in 7.2.1
- apache-airflow-providers-amazon (PyPI): affected all versions; fixed in 7.2.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-25956/ (Markdown: https://insights.sbomify.com/CVE-2023-25956/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-25956
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-25956
- OSV: https://osv.dev/vulnerability/CVE-2023-25956

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-25956/
Summaries are generated and may contain mistakes; the official description above is the record.
