# CVE-2023-26031: Privilege escalation in Apache Hadoop Yarn container-executor binary on Linux systems

> Local attackers can gain root privileges via malicious library injection in the container-executor binary, potentially affecting remote users if YARN secure containers are enabled.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Nov 2023
- **Updated:** 13 Feb 2025
- **Also known as:** GHSA-94jh-j374-9r3j

## What is CVE-2023-26031?

CVE-2023-26031 is a high-severity vulnerability in Apache Hadoop, published on 16 Nov 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Relative library resolution in linux container-executor binary in Apache Hadoop 3.3.1-3.3.4 on Linux allows local user to gain root privileges. If the YARN cluster is accepting work from remote (authenticated) users, this MAY permit remote users to gain root privileges.

Hadoop 3.3.0 updated the " YARN Secure Containers https://hadoop.apache.org/docs/stable/hadoop-yarn/hadoop-yarn-site/SecureContainer.html " to add a feature for executing user-submitted applications in isolated linux containers.

The native binary HADOOP_HOME/bin/container-executor is used to launch these containers; it must be owned by root and have the suid bit set in order for the YARN processes to run the containers as the specific users submitting the jobs.

The patch " YARN-10495 https://issues.apache.org/jira/browse/YARN-10495 . make the rpath of container-executor configurable" modified the library loading path for loading .so files from "$ORIGIN/" to ""$ORIGIN/:../lib/native/". This is the a path through which libcrypto.so is located. Thus it is is possible for a user with reduced privileges to install a malicious libcrypto library into a path to which they have write access, invoke the container-executor command, and have their modified library executed as root.
If the YARN cluster is accepting work from remote (authenticated) users, and these users' submitted job are executed in the physical host, rather than a container, then the CVE permits remote users to gain root privileges.

The fix for the vulnerability is to revert the change, which is done in  YARN-11441 https://issues.apache.org/jira/browse/YARN-11441 , "Revert YARN-10495". This patch is in hadoop-3.3.5.

To determine whether a version of container-executor is vulnerable, use the readelf command. If the RUNPATH or RPATH value contains the relative path "./lib/native/" then it  is at risk

$ readelf -d container-executor|grep 'RUNPATH\|RPATH' 
0x000000000000001d (RUNPATH)            Library runpath: [$ORIGIN/:../lib/native/]

If it does not, then it is safe:

$ readelf -d container-executor|grep 'RUNPATH\|RPATH' 
0x000000000000001d (RUNPATH)            Library runpath: [$ORIGIN/]

For an at-risk version of container-executor to enable privilege escalation, the owner must be root and the suid bit must be set

$ ls -laF /opt/hadoop/bin/container-executor
---Sr-s---. 1 root hadoop 802968 May 9 20:21 /opt/hadoop/bin/container-executor

A safe installation lacks the suid bit; ideally is also not owned by root.

$ ls -laF /opt/hadoop/bin/container-executor
-rwxr-xr-x. 1 yarn hadoop 802968 May 9 20:21 /opt/hadoop/bin/container-executor

This configuration does not support Yarn Secure Containers, but all other hadoop services, including YARN job execution outside secure containers continue to work.

Weakness: CWE-426 (Untrusted Search Path)

## Which versions are affected by CVE-2023-26031?

2 open source packages ship an affected version, including org.apache.hadoop:hadoop-yarn-project. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.hadoop:hadoop-yarn-project` | Maven | From 3.3.1 | 3.3.5 |
| `org.apache.hadoop:hadoop-yarn-project` | Maven | From 3.3.1 | 3.3.5 |

Products: Apache Hadoop.

## How do I fix CVE-2023-26031?

Upgrade org.apache.hadoop:hadoop-yarn-project to 3.3.5 or later.

## Is CVE-2023-26031 being exploited?

There is no known exploitation of CVE-2023-26031 in the wild and no public exploit code.

## Other vulnerabilities in Apache Hadoop

- [CVE-2022-25168](https://insights.sbomify.com/CVE-2022-25168/): Command injection in org.apache.hadoop.fs.FileUtil.unTarUsingTar (critical 9.8)
- [CVE-2021-37404](https://insights.sbomify.com/CVE-2021-37404/): Heap buffer overflow in libhdfs native library (critical 9.8)
- [CVE-2022-26612](https://insights.sbomify.com/CVE-2022-26612/): Arbitrary file write in FileUtil#unpackEntries on Windows (critical 9.8)
- [CVE-2019-17195](https://insights.sbomify.com/CVE-2019-17195/): Improper Check for Unusual or Exceptional Conditions in Connect2id Nimbus JOSE+JWT (critical 9.8)
- [CVE-2017-15718](https://insights.sbomify.com/CVE-2017-15718/): Exposure of Sensitive Information in Hadoop (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-26031 and fix it if it is affected.

What it is: CVE-2023-26031 is a high-severity vulnerability in Apache Hadoop, published on 16 Nov 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-26031 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.hadoop:hadoop-yarn-project (Maven): affected from 3.3.1; fixed in 3.3.5
- org.apache.hadoop:hadoop-yarn-project (Maven): affected from 3.3.1; fixed in 3.3.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-26031/ (Markdown: https://insights.sbomify.com/CVE-2023-26031/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-26031
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-26031
- OSV: https://osv.dev/vulnerability/CVE-2023-26031

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-26031/
Summaries are generated and may contain mistakes; the official description above is the record.
