# CVE-2023-26035: ZoneMinder vulnerable to Missing Authorization

> Unauthenticated attackers can execute arbitrary code via the snapshot action due to missing authorization checks in ZoneMinder.

- **Severity:** High 7.2 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Feb 2023
- **Updated:** 13 Feb 2025
- **Also known as:** DEBIAN-CVE-2023-26035, GHSA-72rg-h4vf-29gr, UBUNTU-CVE-2023-26035

## What is CVE-2023-26035?

CVE-2023-26035 is a high-severity missing authorization vulnerability in Zoneminder Zoneminder, published on 25 Feb 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

ZoneMinder is a free, open source Closed-circuit television software application for Linux which supports IP, USB and Analog cameras. Versions prior to 1.36.33 and 1.37.33 are vulnerable to Unauthenticated Remote Code Execution via Missing Authorization. There are no permissions check on the snapshot action, which expects an id to fetch an existing monitor but can be passed an object to create a new one instead. TriggerOn ends up calling shell_exec using the supplied Id. This issue is fixed in This issue is fixed in versions 1.36.33 and 1.37.33.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2023-26035?

It affects 1 product.


Products: Zoneminder Zoneminder.

## How do I fix CVE-2023-26035?

Upgrade to a fixed version.

## Is CVE-2023-26035 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-26035 exists.

Public exploit code:

- Unauthenticated RCE in ZoneMinder Snapshots - Poc Exploit (github_poc): https://github.com/rvzsec/CVE-2023-26035
- POC script for CVE-2023-26035 (zoneminder 1.36.32)  (github_poc): https://github.com/heapbytes/CVE-2023-26035
- ZoneMinder Snapshots - Unauthenticated (github_poc): https://github.com/Yuma-Tsushima07/CVE-2023-26035
- Exploit for CVE-2023-26035 affecting ZoneMinder < 1.36.33 and < 1.37.33 (github_poc): https://github.com/0xfalafel/zoneminder_CVE-2023-26035
- ZoneMinder Snapshots Command Injection (metasploit)
- This is a script written in Python that allows the exploitation of the Zoneminder's security flaw described in CVE-2023-26035.  (github_poc): https://github.com/m3m0o/zoneminder-snapshots-rce-poc

## Other vulnerabilities in Zoneminder Zoneminder

- [CVE-2008-3882](https://insights.sbomify.com/CVE-2008-3882/): Command injection in n/a (critical 10.0)
- [CVE-2025-65791](https://insights.sbomify.com/CVE-2025-65791/): Command injection in n/a (critical 9.8)
- [CVE-2024-43360](https://insights.sbomify.com/CVE-2024-43360/): ZoneMinder Time-based SQL Injection (critical 9.8)
- [CVE-2022-29806](https://insights.sbomify.com/CVE-2022-29806/): Path traversal in n/a (critical 9.8)
- [CVE-2019-8423](https://insights.sbomify.com/CVE-2019-8423/): SQL injection in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-26035 and fix it if it is affected.

What it is: CVE-2023-26035 is a high-severity missing authorization vulnerability in Zoneminder Zoneminder, published on 25 Feb 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-26035 exists.

Affected product: Zoneminder Zoneminder. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-26035/ (Markdown: https://insights.sbomify.com/CVE-2023-26035/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-26035
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-26035
- OSV: https://osv.dev/vulnerability/CVE-2023-26035

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-26035/
Summaries are generated and may contain mistakes; the official description above is the record.
