{"answers":{"affected":"3 open source packages ship an affected version, including geonode and GeoNode. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-26043 exists.","fix":"Upgrade geonode to 4.0.3 or later.","what":"CVE-2023-26043 is a medium-severity vulnerability in geonode, published on 27 Feb 2023. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-26043 and fix it if it is affected.\n\nWhat it is: CVE-2023-26043 is a medium-severity vulnerability in geonode, published on 27 Feb 2023. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-26043 exists.\n\nAffected packages and fixed versions:\n- geonode (PyPI): affected all versions; fixed in 4.0.3\n- geonode (PyPI): affected all versions; fixed in 4.0.3\n- GeoNode (PyPI): affected all versions; fixed in 4.0.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-26043/ (Markdown: https://insights.sbomify.com/CVE-2023-26043/index.md)","id":"CVE-2023-26043","markdown":"https://insights.sbomify.com/CVE-2023-26043/index.md","name":"CVE-2023-26043","record":{"aliases":["GHSA-mcmc-c59m-pqq8","PYSEC-2023-15"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"GeoNode geospatial platform","requires_auth":"low_privilege","summary":"An attacker can exploit an XML External Entity vulnerability in GeoNode's style upload to read arbitrary files from the server.","user_interaction":"not_required","vuln_class":"xxe"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"geonode","vendor":"geosolutionsgroup"}],"cvss":{"score":6.5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-611","name":"Improper Restriction of XML External Entity Reference"}],"description":"GeoNode is an open source platform that facilitates the creation, sharing, and collaborative use of geospatial data. GeoNode is vulnerable to an XML External Entity (XXE) injection in the style upload functionality of GeoServer leading to Arbitrary File Read. This issue has been patched in version 4.0.3.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"XML External Entity (XXE) injection in GeoServer style upload functionality","id":"CVE-2023-26043","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"xxe","year":"2023"},"n_packages":3,"n_references":2,"next":{"headline":"ReactPHP's HTTP server continues parsing unused multipart parts after reaching limits","id":"CVE-2023-26044"},"packages":[{"ecosystem":"PyPI","fixed":["4.0.3"],"introduced":["0"],"last_affected":[],"package":"GeoNode","purl":null,"source":"GHSA-mcmc-c59m-pqq8"},{"ecosystem":"PyPI","fixed":["4.0.3"],"introduced":["0"],"last_affected":[],"package":"geonode","purl":"pkg:pypi/geonode","source":"GHSA-mcmc-c59m-pqq8"},{"ecosystem":"PyPI","fixed":["4.0.3"],"introduced":["0"],"last_affected":[],"package":"geonode","purl":"pkg:pypi/geonode","source":"PYSEC-2023-15"}],"prev":{"headline":"HTML/XSS injection possibilities in Part-DB","id":"CVE-2023-26042"},"products":["geonode"],"published":"2023-02-27","related":[{"cvss_score":7.5,"headline":"GeoNode SSRF Bypass to return internal host data","id":"CVE-2023-42439","kev_date_added":null,"published":"2023-09-15"},{"cvss_score":7.5,"headline":"Geonode Server Side Request Forgery vulnerability","id":"CVE-2023-40017","kev_date_added":null,"published":"2023-08-24"},{"cvss_score":7.5,"headline":"Geoserver for GeoNode sensitive information leak","id":"CVE-2023-28442","kev_date_added":null,"published":"2023-03-23"},{"cvss_score":6.1,"headline":"GeoNode stored XSS to full account takeover","id":"CVE-2024-27091","kev_date_added":null,"published":"2024-03-27"},{"cvss_score":5.3,"headline":"GeoNode \u003c 4.4.5, 5.0.2 SSRF via Document Upload","id":"CVE-2026-39921","kev_date_added":null,"published":"2026-04-10"},{"cvss_score":5.3,"headline":"GeoNode SSRF via Service Registration","id":"CVE-2026-39922","kev_date_added":null,"published":"2026-04-10"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-03-10","vendors":["GeoNode"]},"summary":"An attacker can exploit an XML External Entity vulnerability in GeoNode's style upload to read arbitrary files from the server.","url":"https://insights.sbomify.com/CVE-2023-26043/"}