# CVE-2023-26043: XML External Entity (XXE) injection in GeoServer style upload functionality

> An attacker can exploit an XML External Entity vulnerability in GeoNode's style upload to read arbitrary files from the server.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Feb 2023
- **Updated:** 10 Mar 2025
- **Also known as:** GHSA-mcmc-c59m-pqq8, PYSEC-2023-15

## What is CVE-2023-26043?

CVE-2023-26043 is a medium-severity vulnerability in geonode, published on 27 Feb 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

GeoNode is an open source platform that facilitates the creation, sharing, and collaborative use of geospatial data. GeoNode is vulnerable to an XML External Entity (XXE) injection in the style upload functionality of GeoServer leading to Arbitrary File Read. This issue has been patched in version 4.0.3.

Weakness: CWE-611 (Improper Restriction of XML External Entity Reference)

## Which versions are affected by CVE-2023-26043?

3 open source packages ship an affected version, including geonode and GeoNode. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `geonode` | PyPI | All versions | 4.0.3 |
| `geonode` | PyPI | All versions | 4.0.3 |
| `GeoNode` | PyPI | All versions | 4.0.3 |

Products: Geosolutionsgroup Geonode.

## How do I fix CVE-2023-26043?

Upgrade geonode to 4.0.3 or later.

## Is CVE-2023-26043 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-26043 exists.

## Other vulnerabilities in geonode

- [CVE-2023-42439](https://insights.sbomify.com/CVE-2023-42439/): GeoNode SSRF Bypass to return internal host data (high 7.5)
- [CVE-2023-40017](https://insights.sbomify.com/CVE-2023-40017/): Geonode Server Side Request Forgery vulnerability (high 7.5)
- [CVE-2023-28442](https://insights.sbomify.com/CVE-2023-28442/): Geoserver for GeoNode sensitive information leak (high 7.5)
- [CVE-2024-27091](https://insights.sbomify.com/CVE-2024-27091/): GeoNode stored XSS to full account takeover (medium 6.1)
- [CVE-2026-39921](https://insights.sbomify.com/CVE-2026-39921/): GeoNode < 4.4.5, 5.0.2 SSRF via Document Upload (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-26043 and fix it if it is affected.

What it is: CVE-2023-26043 is a medium-severity vulnerability in geonode, published on 27 Feb 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-26043 exists.

Affected packages and fixed versions:
- geonode (PyPI): affected all versions; fixed in 4.0.3
- geonode (PyPI): affected all versions; fixed in 4.0.3
- GeoNode (PyPI): affected all versions; fixed in 4.0.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-26043/ (Markdown: https://insights.sbomify.com/CVE-2023-26043/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-26043
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-26043
- OSV: https://osv.dev/vulnerability/CVE-2023-26043

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-26043/
Summaries are generated and may contain mistakes; the official description above is the record.
