{"answers":{"affected":"2 open source packages ship an affected version, including react/http. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-26044 in the wild and no public exploit code.","fix":"Upgrade react/http to 1.9.0 or later.","what":"CVE-2023-26044 is a medium-severity denial of service vulnerability in reactphp http, published on 17 May 2023. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-26044 and fix it if it is affected.\n\nWhat it is: CVE-2023-26044 is a medium-severity denial of service vulnerability in reactphp http, published on 17 May 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-26044 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- react/http (Packagist): affected from 0.8.0; fixed in 1.9.0\n- react/http (Packagist): affected from 0.8.0; fixed in 1.9.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-26044/ (Markdown: https://insights.sbomify.com/CVE-2023-26044/index.md)","id":"CVE-2023-26044","markdown":"https://insights.sbomify.com/CVE-2023-26044/index.md","name":"CVE-2023-26044","record":{"aliases":["GHSA-95x4-j7vc-h8mf","UBUNTU-CVE-2023-26044"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":true,"product_category":"ReactPHP HTTP server","requires_auth":"none","summary":"Attackers can cause high CPU load and service delays by sending large HTTP bodies when specific middleware is configured with high limits.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"http","vendor":"reactphp"}],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L","version":"3.1"},"cwes":[{"id":"CWE-400","name":"Uncontrolled Resource Consumption"}],"description":"react/http is an event-driven, streaming HTTP client and server implementation for ReactPHP.  Previous versions of ReactPHP's HTTP server component contain a potential DoS vulnerability that can cause high CPU load when processing large HTTP request bodies. This vulnerability has little to no impact on the default configuration, but can be exploited when explicitly using the RequestBodyBufferMiddleware with very large settings. This might lead to consuming large amounts of CPU time for processing requests and significantly delay or slow down the processing of legitimate user requests. This issue has been addressed in release 1.9.0. Users are advised to upgrade. Users unable to upgrade may keep the request body limited using RequestBodyBufferMiddleware with a sensible value which should mitigate the issue. An infrastructure or DevOps workaround could be to place a reverse proxy in front of the ReactPHP HTTP server to filter out any excessive HTTP request bodies.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"ReactPHP's HTTP server continues parsing unused multipart parts after reaching limits","id":"CVE-2023-26044","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"denial_of_service","year":"2023"},"n_packages":2,"n_references":2,"next":{"headline":"NodeBB vulnerable to path traversal and code execution via prototype vulnerability","id":"CVE-2023-26045"},"packages":[{"ecosystem":"Packagist","fixed":["1.9.0"],"introduced":["0.8.0"],"last_affected":[],"package":"react/http","purl":null,"source":"GHSA-95x4-j7vc-h8mf"},{"ecosystem":"Packagist","fixed":["1.9.0"],"introduced":["0.8.0"],"last_affected":[],"package":"react/http","purl":"pkg:composer/react/http","source":"GHSA-95x4-j7vc-h8mf"}],"prev":{"headline":"XML External Entity (XXE) injection in GeoServer style upload functionality","id":"CVE-2023-26043"},"products":["http"],"published":"2023-05-17","related":[{"cvss_score":5.3,"headline":"ReactPHP's HTTP server parses encoded cookie names so malicious `__Host-` and `__Secure-` cookies can be sent","id":"CVE-2022-36032","kev_date_added":null,"published":"2022-09-06"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-01-23","vendors":["reactphp"]},"summary":"Attackers can cause high CPU load and service delays by sending large HTTP bodies when specific middleware is configured with high limits.","url":"https://insights.sbomify.com/CVE-2023-26044/"}