{"answers":{"affected":"4 open source packages ship an affected version, including frappant/frp-form-answers. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-26091 in the wild and no public exploit code.","fix":"Upgrade frappant/frp-form-answers to a fixed version for your release line: 3.1.2 or 4.0.2.","what":"CVE-2023-26091 is a medium-severity cross-site scripting vulnerability in n/a, published on 26 Feb 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2023-26091 and fix it if it is affected.\n\nWhat it is: CVE-2023-26091 is a medium-severity cross-site scripting vulnerability in n/a, published on 26 Feb 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2023-26091 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- frappant/frp-form-answers (Packagist): affected all versions; fixed in 3.1.2\n- frappant/frp-form-answers (Packagist): affected all versions; fixed in 3.1.2\n- frappant/frp-form-answers (Packagist): affected from 4.0.0; fixed in 4.0.2\n- frappant/frp-form-answers (Packagist): affected from 4.0.0; fixed in 4.0.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-26091/ (Markdown: https://insights.sbomify.com/CVE-2023-26091/index.md)","id":"CVE-2023-26091","markdown":"https://insights.sbomify.com/CVE-2023-26091/index.md","name":"CVE-2023-26091","record":{"aliases":["GHSA-q3r2-23r8-wqr9"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"TYPO3 Forms Export","requires_auth":"none","summary":"An attacker can execute arbitrary scripts in the context of other users via saved emails in the TYPO3 Forms Export extension.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"forms_export","vendor":"frappant"}],"cvss":{"score":6.1,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"The frp_form_answers (aka Forms Export) extension before 3.1.2, and 4.x before 4.0.2, for TYPO3 allows XSS via saved emails.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"frp_form_answers allows Cross-site Scripting","id":"CVE-2023-26091","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2023"},"n_packages":4,"n_references":2,"next":{"headline":"Liima before 1.17.28 allows server-side template injection.","id":"CVE-2023-26092"},"packages":[{"ecosystem":"Packagist","fixed":["3.1.2"],"introduced":["0"],"last_affected":[],"package":"frappant/frp-form-answers","purl":null,"source":"GHSA-q3r2-23r8-wqr9"},{"ecosystem":"Packagist","fixed":["3.1.2"],"introduced":["0"],"last_affected":[],"package":"frappant/frp-form-answers","purl":"pkg:composer/frappant/frp-form-answers","source":"GHSA-q3r2-23r8-wqr9"},{"ecosystem":"Packagist","fixed":["4.0.2"],"introduced":["4.0.0"],"last_affected":[],"package":"frappant/frp-form-answers","purl":null,"source":"GHSA-q3r2-23r8-wqr9"},{"ecosystem":"Packagist","fixed":["4.0.2"],"introduced":["4.0.0"],"last_affected":[],"package":"frappant/frp-form-answers","purl":"pkg:composer/frappant/frp-form-answers","source":"GHSA-q3r2-23r8-wqr9"}],"prev":{"headline":"Hardcoded credentials in n/a","id":"CVE-2023-26089"},"products":["n/a"],"published":"2023-02-26","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-03-11","vendors":["n/a"]},"summary":"An attacker can execute arbitrary scripts in the context of other users via saved emails in the TYPO3 Forms Export extension.","url":"https://insights.sbomify.com/CVE-2023-26091/"}